Closed Bug 964990 Opened 6 years ago Closed 6 years ago

Build bustage: ManifestParser.cpp: 'GetVersionExA': was declared deprecated

Categories

(Core :: General, defect, blocker)

x86_64
Windows 7
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 965008

People

(Reporter: mayhemer, Unassigned)

Details

VC10, debug build, https://hg.mozilla.org/mozilla-central/rev/0eb2ba65a702


 2:41.74 Warning: C4996 in c:\Mozilla\src\gum\xpcom\components\ManifestParser.cpp: 'GetVersionExA': was declared deprecated
 2:41.74 c:/Mozilla/src/gum/xpcom/components/ManifestParser.cpp(455) : error C2220: warning treated as error - no 'object' file generated
 2:41.74 c:/Mozilla/src/gum/xpcom/components/ManifestParser.cpp(455) : warning C4996: 'GetVersionExA': was declared deprecated
 2:41.74         C:\Program Files (x86)\Windows Kits\8.1\Include\um\sysinfoapi.h(433) : see declaration of 'GetVersionExA'
 2:41.74


mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/_obj-browser-debug
mk_add_options MOZ_MAKE_FLAGS=-j9

export MOZ_DEBUG_SYMBOLS=1

ac_add_options --enable-application=browser
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --enable-shared

ac_add_options --disable-static
ac_add_options --enable-tests
ac_add_options --enable-logging
ac_add_options --enable-backtrack
ac_add_options --disable-installer
ac_add_options --enable-chrome-format=flat
ac_add_options --enable-warnings-as-errors

ac_add_options --disable-crashreporter
ac_add_options --disable-directshow # 905592
Used to work one week back.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925599
Actually bug 965008.
Duplicate of bug: 965008
You need to log in before you can comment on or make changes to this bug.