Compat validation for Firefox 27 showing tons of 'Relection failed' errors

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Compatibility Tools
--
critical
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: jorgev, Assigned: clouserw)

Tracking

Details

(Reporter)

Description

4 years ago
I expected this bulk validation to yield a couple dozen failures at most, but I got over one thousand. It looks like something broke this time around, because all failures I've seen so far have errors like this:

https://addons.mozilla.org/en-US/developers/addon/imgcluborg-image-uploader/validation-result/257091

The message reads:

> JS reflection error prevented validation
>
> Error: An error in the JavaScript file prevented it from being properly read by the Spidermonkey
> JS engine.
>
> 'Reflection failed'

These messages point to XUL and XML files, not JS, and we're speculating that the problem is being caused by the event handlers in the files (oncommand="some JS here"). However, this hasn't happened before and doesn't appear to be happening for regular validations. I could be some change in the last push or maybe even bug 961270.

I need this fixed ASAP so I can do the Firefox 27 compatibility push, which is due on Monday and should happen as early as possible to give developers time to prepare.
(Assignee)

Comment 1

4 years ago
Did you test this on -dev first?  It's not clear why it would fail
(Assignee)

Comment 2

4 years ago
The Fx27 tests didn't go out earlier so we're not sure why this would fail (in theory, they should all pass).  We've pushed the tests out now so it should work, but still a bit unclear.  Can you test on -dev?
(Reporter)

Comment 3

4 years ago
I just ran the validation on -dev and the results match what I would expect (less than 100 failures). It could be that something else breaks if the validation is run with no tests for that version, but the symptoms are very strange.

I can try on prod again, but I think bug 965156 needs to be addressed first, since it appears the test wasn't added in the right category.
(Assignee)

Comment 4

4 years ago
I think this ran correctly, yes?  I got the email for my add-on at least.
(Reporter)

Comment 5

4 years ago
Since the fix wasn't available for testing on Friday, the emails were sent using the results from the previous run. That means a bunch of people got failure messages when they shouldn't, but I explained that in the message they got.

We will have to test this again with the Firefox 28 compat bump to see if there are any improvements.
(Reporter)

Comment 6

4 years ago
This didn't happen for the Firefox 28 compatibility upgrade, so I think the fix did work.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.