[B2G][Everything.me] Many apps do not show that they have already been added to the Homescreen

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mvaughan, Assigned: crdlc)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, firefox29 affected, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8367004 [details]
Video of issue occurring with Facebook app.

Description:
Many of the apps that the user can add to the Homescreen from Everything.me do not tell the user if they have already been added to the Homescreen. There are some other apps that do tell the user however, which creates an inconsistency for alerts.

Repro Steps:
1) Updat Buri to BuildID: 20140128040224
2) Navigate to the 'Social' Smart Collection
3) Long tap Facebook (or Google+, Tumblr, Flickr, etc.)
4) Select "Save to Homescreen"
5) Repeat steps 3 & 4 once using same app

Actual:
Alert is not given to the user that the chosen app has already been added to the Homescreen.

Expected:
User is given an alert that the chosen app has already been added to the Homescreen (Twitter is one app that WILL alert the user it has already been installed).

Environmental Variables:
Device: Buri Master (1.4) MOZ RIL
BuildID: 20140128040224
Gaia: 6586d2b8b43c6997be5cf5895bbdf3dd20490725
Gecko: 4da3e21a0e5f
Version: 29.0a1
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 5/5
See attached: AlreadyAddedAlert.mpeg

This issue reproduces on the 01/28/14 Master (1.4).
This issue does not reproduce on the 01/28/14 1.2.
Saw this myself - the UX here is highly inconsistent.
The regression however feels minor - the user is getting awareness that the task is complete & knows something is present of the homescreen. The only confusion here is the way it's messaged.
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
Created attachment 8367174 [details]
Patch v1

We forgot to add this code when we fixed the collision between apps and bookmars :)
Attachment #8367174 - Flags: review?(ran)
Comment on attachment 8367174 [details]
Patch v1

Great! Nice catch.
Attachment #8367174 - Flags: review?(ran) → review+
(Assignee)

Comment 5

5 years ago
Merged in master:

https://github.com/crdlc/gaia/commit/65f6b1ad6da0760cd946fada0fdcdf2ef4eaa0d9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
According to status flags, I think we should ask to be a blocker for 1.3
blocking-b2g: --- → 1.3?
Unblocking for 1.3
blocking-b2g: 1.3? → -
Duplicate of this bug: 969534
You need to log in before you can comment on or make changes to this bug.