Firefox developer tools DOM missing if tools are enabled on refresh

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: florin arjocu, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140203], URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206145143

Steps to reproduce:

Open Developer Tools. Use it. Refresh the page (don't close the dev tools). See this private screen recording: https://www.youtube.com/watch?v=h3wZeJ_DXj8


Actual results:

The DOM part of the developer tools is blank. Even if I select an element from the page it remains blank.


Expected results:

Should loat the DOM.
(Reporter)

Comment 1

4 years ago
Completion:


Expected results: Should load the DOM and position on the exact element it was positioned before refreshing, just like Firebug.

Comment 2

4 years ago
bug: 2013-09-24-03-02-02-mozilla-central-firefox-27.0a1.en-US.linux-x86_64
WFM: 2013-10-10-03-02-02-mozilla-central-firefox-27.0a1.en-US.linux-x86_64
…
WFM: 2014-02-03-03-02-03-mozilla-central-firefox-29.0a1.en-US.linux-x86_64.

Seems fixed; please reopen if not.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → Developer Tools: Inspector
Resolution: --- → WORKSFORME
Whiteboard: [bugday-20140203]

Updated

3 years ago
Duplicate of this bug: 951787
You need to log in before you can comment on or make changes to this bug.