overflow:visible not working on FIELDSETs

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
17 years ago
15 years ago

People

(Reporter: Robert McDonald, Assigned: Bernd)

Tracking

({css2, testcase})

Trunk
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

The "search via FirstGov now" button is positioned incorrectly, with part of the
button not doing anything. The page has a box which is drawn incorrectly. IE 5.5
seems to position everything right.



Reproducible: Always
Steps to Reproduce:
1. Go to the URL above.
2.
3.

Comment 1

17 years ago
Browser, not engine --> Layout
Assignee: rogerl → karnaze
Component: Javascript Engine → Layout
QA Contact: pschwartau → petersen

Comment 2

17 years ago
Created attachment 46811 [details]
Testcase

Comment 3

17 years ago
Problem seems to be a FIELDSET with a (insufficiently) specified CSS height.
Some form controls are not visible. ->HTMLFormControls for further triage.
Assignee: karnaze → rods
Component: Layout → HTML Form Controls
Keywords: testcase
QA Contact: petersen → madhur
No dupes found. Confirming and marking NEW. 

This may end up as Evangelism, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

17 years ago
The FIELDSET has a CSS specified height of 95px but the content requires more.
The current behaviour acts as if the FIELDSET has "overflow:hidden" but
I thought "overflow:visible" was the default. Do form controls have a different
default value for the CSS overflow property?
In fact, the testcase doesn't display differently even if I add "overflow:visible"
to the FIELDSET.
Keywords: css2

Comment 6

16 years ago
Reconfirmed using FizzillaCFM/2002071208. Setting All/All, and trying a revised
Summary. This probably belongs on Style System or Layout; trying Style System first.
Assignee: rods → dbaron
Status: ASSIGNED → NEW
Component: HTML Form Controls → Style System
OS: Windows NT → All
QA Contact: madhur → ian
Hardware: PC → All
Summary: Page rendered incorrectly → overflow:visible not working on FIELDSETs
No, this belongs in form controls.  Fieldset is a hard-coded layout object
(nsIFrame) right now.
Assignee: dbaron → rods
Component: Style System → HTML Form Controls
QA Contact: ian → tpreston
.
Assignee: rods → form
QA Contact: tpreston → desale
Target Milestone: Future → ---

Comment 9

15 years ago
Created attachment 124953 [details]
Crash Mozilla with fieldset with style position:fixed and a legend as child
(Assignee)

Comment 10

15 years ago
Created attachment 131809 [details] [diff] [review]
patch
(Assignee)

Updated

15 years ago
Attachment #131809 - Flags: superreview?(dbaron)
Attachment #131809 - Flags: review?(dbaron)
(Assignee)

Comment 11

15 years ago
taking the bug
Assignee: form → bernd_mozilla
Attachment #131809 - Flags: superreview?(dbaron)
Attachment #131809 - Flags: superreview+
Attachment #131809 - Flags: review?(dbaron)
Attachment #131809 - Flags: review+
(Assignee)

Comment 12

15 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.