Rename JS "worker" threads to something else. Please. Please. Pretty please!

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: bent.mozilla, Assigned: bhackett)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

We're getting lots of confusion over the fact that the JS engine names all their utility threads "workers" and the DOM has Web Workers. Can we please rename the JS threads to "utility" threads? "Helpers"? "Minions"? Anything would be wonderful.
Let's call them "esdiscuss threads", that probably won't confuse anyone
I asked on IRC.

<dom_workers> YES PLEASE i hate being confused with these losers
<ion_workers> i don't really care, whatever
<asmjs_workers> Oh! I see. That seems entirely reasonable.
<pjs_workers> Why should I change? He's the one that sucks.
Assignee: nobody → jorendorff
bhackett and I decided in another bug (I can't remember which one) to call them "helper" threads.
-> Helper Monkeys
(In reply to Nicholas Nethercote [:njn] from comment #3)
> bhackett and I decided in another bug (I can't remember which one) to call
> them "helper" threads.

This is what I'm doing. Except PJS threads will be called "fork-join threads".

Helper threads and fork-join threads share a workerId number space and I'm not totally sure what I'll call that yet; I'd pick "threadId" except NSPR has a concept of "thread id" and they're two different things.
(In reply to Jason Orendorff [:jorendorff] from comment #5)
> (In reply to Nicholas Nethercote [:njn] from comment #3)
> > bhackett and I decided in another bug (I can't remember which one) to call
> > them "helper" threads.
> 
> This is what I'm doing. Except PJS threads will be called "fork-join
> threads".
> 
> Helper threads and fork-join threads share a workerId number space and I'm
> not totally sure what I'll call that yet; I'd pick "threadId" except NSPR
> has a concept of "thread id" and they're two different things.

If you're doing these mass renamings, ThreadPool should probably be ForkJoinPool or something. I don't see how you can avoid overloading "threadId" though. It just seems context-sensitive and confusing no matter what.
Assignee: jorendorff → bhackett1024
Posted patch part 1Splinter Review
Rename WorkerThread stuff to HelperThread stuff.  After this lands I'll write patches to rename the jsworkers files themselves, and the PJS worker nomenclature.
Attachment #8431180 - Flags: review?(jorendorff)
Attachment #8431180 - Flags: review?(jorendorff) → review+
Posted patch part 2Splinter Review
Rename jsworkers.* to vm/HelperThreads.*
Attachment #8431599 - Flags: review?(jorendorff)
Attachment #8431599 - Flags: review?(jorendorff) → review+
Is there a reason this is still left open?
Flags: needinfo?(bhackett1024)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bhackett1024)
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.