[B2G][Gaia][Homescreen][e.me] Scrolling rapidly back and forth on the home screen can cause a soft lock with everything.me

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: lmauritson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3, URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8367026 [details]
logcat_20140128_1158.txt

Description:
Scrolling rapidly back and forth with tapping the "I'm thinking of..." text box can cause the device to enter a state where the user cannot exit the text entry state. (See video)

Repro Steps:
1) Update a Buri to BuildID: 20140127004002
2) On the home screen rapidly scroll back and forth, moving icons.
3) Occasionally while moving back and forth, tap the "I'm thinking of..." text box, but do not type anything in.
4) If they keyboard appears, tap the screen above it to dismiss it.
5) Carry on in this fashion until a softlock occurs where the user cannot enter text in the text box to continue.

Actual:
The user becomes stuck on the page with the "I'm thinking of..." text box, the keyboard will disappear and the is unable to scroll to a new page or cancel text entry.

Expected:
Rapidly scrolling back and forth causes no issues. The keyboard does not disappear when a text entry box is selected. The user can always cancel and back out of text entry.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140127004002
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Gecko: c40099a42c1f
Version: 28.0a2
Firmware Version: v1.2-device.cfg


Notes: It is not likely that a user would encounter this issue during normal use.

Repro frequency: Rare, out of 10 times this occurred twice.
See attached: http://youtu.be/N4AaRA7EifU?t=2m45s

Updated

5 years ago
Component: Gaia::Everything.me → Gaia::Homescreen

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964997
BTW, since I don't think this was a dupe of bug 964997 I think somebody should retest it now the other bug is fixed. If it no longer happens this can be re-duped or closed as WFM. I don't want to assume it's fixed though.
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

5 years ago
After about 5 minutes of swiping back and forth rapidly on the screen I got this to happen again.
The only steps I can offer are to go crazy with the screen for a few minutes, and if an app opens keep swiping back and forth, if it persists hit the home button and continue. Tap the everything.me bar or app icons and then quickly swipe to another page, and try to make the keyboard stay up in places it shouldn't be if possible.

I did have icons on a third page which seemed to help the scrolling get confused.
Also, after a minute or two I noticed the loading bar at the top of the screen even while in the home menu.

Sometimes the keyboard will persist in places it shouldn't, sometimes random apps open, sometimes the home screen becomes blanks with no icons. Eventually it gets in to a state where the text box of one of the everything.me apps up top appears the be in the foreground (Nothing can be entered) while the icons are in the background and I am unable to leave that state without restarting the device.

I hope that helps.


1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140205004002
Gaia: 3405c205cfb5625073b9db1e12ed5d173bdcc78c
Gecko: 2c7f237ba88b
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.