[DSDS] SIM manager will set all outgoing settings to SIM 2 after reboot device.

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Enpei, Assigned: rik)

Tracking

({regression})

unspecified
x86_64
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 verified, b2g-v1.4 fixed)

Details

(Whiteboard: dsdsrun1.3)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8367156 [details]
time stamp: 15:51, 1/29

Even all outgoing settings are set to SIM 1, after reboot, all settings will be changed to SIM 2. It's like there is time after reboot that device thinks that there is no SIM 1.

* Build Number  
Gaia      77fdf058ccb77f40497fb696912a1ce12192eea7
Gecko     9c7f92ffaa19db4a004103104d2da78b8cbd2056
BuildID   20140129130749
Version   28.0a2

* Reproduce Steps
1. Set all outgoing settings to SIM 1 in SIM manager.
2. Reboot device.

* Expected Result
Settings no changed.

* Actual Result
Data call changed to SIM 2, then go to SIM manager, all are set to SIM 2.

* Occurrence rate
100%
(Reporter)

Comment 1

4 years ago
Previous build has no such problem.
Worked:
Gaia      1318d1612299ba5d86820bbb6a65ae090f3b2fd6
Gecko     af909ff1dce5d69871146f4b44d13b2c877f9bca
BuildID   20140126061645
Version   28.0a2
blocking-b2g: --- → 1.3?
Keywords: regression
(Reporter)

Comment 2

4 years ago
1/28 build has no such problem as well.

Worked:
Gaia      cb6280606e1a306b13bb48e45fb3fcd940ff9f71
Gecko     8bf76ed551b5717c894ff43ee54498e8b470caa5
BuildID   20140128061636
Version   28.0a2

Failed:
Gaia      77fdf058ccb77f40497fb696912a1ce12192eea7
Gecko     9c7f92ffaa19db4a004103104d2da78b8cbd2056
BuildID   20140129130749
Version   28.0a2
1.3+ for regression
blocking-b2g: 1.3? → 1.3+
This issue was regressed by bug 958412. The root cause is that there is no good timing for gaia to check the count of the inserted sim cards. A workaround would be adding a timeout if the time of detecting sim cards are fixed across devices.
Assignee: nobody → kaze
un-assigning kaze for someone to steal this bug.
Assignee: kaze → nobody
(Assignee)

Updated

4 years ago
Assignee: nobody → anthony
(Assignee)

Comment 6

4 years ago
The code relies on a simslot-updated event sent by simslot.js. I'm wondering if we could listen to another event that is dispatched later.
The first simslot-updated is dispatched due to the iccdetected event from mozIccManager. If there is only one sim card inserted, there will be only one simslot-updated event dispatched.
(Assignee)

Comment 8

4 years ago
Created attachment 8368655 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/15874

I used a one second timeout.
Attachment #8368655 - Flags: review?(etienne)
(In reply to Anthony Ricaud (:rik) from comment #8)
> Created attachment 8368655 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/15874
> 
> I used a one second timeout.

Well let's not brag about this :)
Comment on attachment 8368655 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/15874

r=me without the underscores in the variables names :)
Attachment #8368655 - Flags: review?(etienne) → review+
(Assignee)

Comment 11

4 years ago
https://github.com/mozilla-b2g/gaia/commit/0cb3631191ef12947e981c0ff35e9d27256972cf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
b0b58dfedadf2be70fbe4d6c90a4e9e53fe03579 on 1.3.
status-b2g-v1.3: --- → fixed
status-b2g-v1.4: --- → fixed
(Reporter)

Comment 13

4 years ago
Verified.

Fugu - 
Gaia      bb36b4164d3e51ca04b612e507e1178f80bf240d
Gecko     4227240a4d3e1e418ced160c2a48cb454d7b5645
BuildID   20140204104742
Version   28.0
Status: RESOLVED → VERIFIED
status-b2g-v1.3: fixed → verified
(In reply to Anthony Ricaud (:rik) from comment #8)
> Created attachment 8368655 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/15874
> 
> I used a one second timeout.

I have thought about this problem for few days .... To be honest, I like this solution indeed xD.

Thanks rik :)
You need to log in before you can comment on or make changes to this bug.