Status

addons.mozilla.org Graveyard
Add-on Validation
--
major
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: dkgo, Assigned: mstriemer)

Tracking

Details

Attachments

(1 attachment)

31.96 KB, image/png
Details
(Reporter)

Description

4 years ago
Created attachment 8367161 [details]
aa.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140128132521

Steps to reproduce:

fxchrome Cannot upload.
get error

No such issues on theme.




Actual results:

Error with fxchrome.xpi
100% complete ยท 3.49 MB of 3.49 MB
Your add-on failed validation with 4 errors.

    The `#downloads-indicator` node was removed from the DOM.
    The `#downloads-indicator` node was removed from the DOM.
    The `#downloads-indicator` node was removed from the DOM.
    The `#downloads-indicator` node was removed from the DOM.
(Reporter)

Comment 1

4 years ago
#downloads-indicator working on fiefox26
I think Validation is a better fit for this than the now-deprecated Builder component.
Component: Add-on Builder → Add-on Validation

Comment 3

4 years ago
I can confirm this one. Validator even refuses already fully reviewed files, if you try to (re)upload them.
Whose idea was to block valid ids like '#downloads-indicator' only because they got removed from 'recent' Fx builds?

It should not be validators business which ids an add-on uses. The reviewer has to put a note, if an id violates something or leads to incompatibilities.
Bug 961270 should've added this as an error for compatibility bumps, but not for all validations.
Assignee: nobody → mstriemer
Blocks: 961270
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

4 years ago
https://github.com/mozilla/amo-validator/commit/cd0edd7f81bb83be810002023730a3a762f27d79
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.