Closed Bug 965324 Opened 6 years ago Closed 6 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.webapp.Dispatcher.onCreate(Dispatcher.java)

Categories

(Firefox for Android :: Web Apps (PWAs), defect, critical)

29 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: aaronmt, Assigned: mhaigh)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-6f7b2300-2a54-4012-a2fc-038ea2140128.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.webapp.Dispatcher.onCreate(Dispatcher.java:30)
	at android.app.Activity.performCreate(Activity.java:5122)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1081)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2270)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2358)
	at android.app.ActivityThread.access$600(ActivityThread.java:156)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1340)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:153)
	at android.app.ActivityThread.main(ActivityThread.java:5297)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:833)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:600)
	at dalvik.system.NativeStart.main(Native Method)
Assignee: nobody → mhaigh
Validate data entering the activity - return early if data is not present
Attachment #8372286 - Flags: feedback?(myk)
Comment on attachment 8372286 [details] [diff] [review]
Validate data entering webapp dispatcher

Review of attachment 8372286 [details] [diff] [review]:
-----------------------------------------------------------------

This looks right to me, regardless of why the bundle is missing, although it sure would be nice to know why it was missing for the user who crashed.  Could it have been someone tapping a homescreen icon created by the old implementation?
Attachment #8372286 - Flags: review?(wjohnston)
Attachment #8372286 - Flags: feedback?(myk)
Attachment #8372286 - Flags: feedback+
I profess to not know much about the old implementation of homescreen icons, so this could be a cause. I also don't know anything about the Socorro interface - is this a general interface for displaying all caught crashes from all users, or is it limited to test devices, or something else?  I will assume the former for now.

To get to the stage that this activity is called without the correct data, an intent would have to be called with a mimeType of "application/webapp".  

Other possible causes:
1, Another application is trying to launch something with this mimetype, which I coined and also can find no other references of on the internet, unlikely but possible; 
2, An incorrectly created APK has been installed.  Last time I checked the server at dapk.net wasn't spitting out correctly built APKS, so this could be a possibility;
3, An early version of a generated APK was launched which didn't include the correct data packaged in with the intent call - I still have dev code and apks around from when we were defining this behaviour, so it is possible that I or someone else accidentally ran one of these.
crash-stats.m.o receives and processes any crash that the user opts into sending. If you want more info please join #crashkill or email stability at mozilla . org.
Attachment #8372286 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/e3b9b91bf893
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8372286 [details] [diff] [review]
Validate data entering webapp dispatcher

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  Bug 934756.
User impact if declined:
  Fennec will crash when a user launches a webapp under certain circumstances.
Testing completed (on m-c, etc.):
  This has been on Central for several days.  No additional crashes have been
  reported via Socorro since then.
Risk to taking this patch (and alternatives if risky):
  The patch is low-risk, as it simply validates input.
String or IDL/UUID changes made by this patch:
  None.
Attachment #8372286 - Flags: approval-mozilla-aurora?
Attachment #8372286 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.