bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Link Properties: Clearing text does not allow removal of existing link

VERIFIED FIXED in mozilla0.9.4

Status

()

Core
Editor
--
minor
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: TucsonTester1, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.3+)
Gecko/20010821 Netscape6/6.1b1
BuildID:    20010821

Link Properties: The Link Properties context panel contains instructions that
cannot be followed.  The statement under the Link Location field says ``(Clear
text to remove existing link form page.),'' however clearing the text does not
allow removal of existing link.  The statement under the Link Location field
says ``(Clear text to remove existing link form page.)''  However if you do so
you have to replace the removed information with something in order to make the
[OK] button available once again.  When the Link Location field is blank the
[OK] button is greyed-out.  The parenthetical instruction implies that one
should be able to ``un-linkify'' a piece of text on a page by clearing the field
and clicking [OK].

Reproducible: Always
Steps to Reproduce:
          (1) Select the link and click Link toolbar icon, 
                    Link Selection from the menu command,
                    or Link Selection from the keyboard 
                    command
          (2) The target web page location appears in the
                    Link Location field
          (3) Following the instructions to clear the text
                    from the field


Actual Results:  The [OK] button is no longer available; it becomes greyed-out.

Expected Results:  Clicking [OK] should return user to the document being edited
and the former link is returned to mere plain text.

This may merely be a cosmetic flaw, instead of a failure in functionality.

Comment 1

17 years ago
-->cmanske
Assignee: brade → cmanske
Hardware: PC → All
(Assignee)

Comment 2

17 years ago
Good catch. This regression was caused by the recent fix for bug 90230.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 3

17 years ago
Created attachment 46892 [details] [diff] [review]
Fix.
(Assignee)

Comment 4

17 years ago
note that this fix removes the line:
SetElementEnabledById("MakeRelativeUrl", enable);
that was accidentally checked in with the fix to 90230. It has no effect, but
should be removed (it is part of the fix for bug 72583, which isn't finished yet.)
Keywords: patch, review
Whiteboard: FIX IN HAND need r=, sr=

Comment 5

17 years ago
sr=kin@netscape.com with parens around the > check.
Whiteboard: FIX IN HAND need r=, sr= → FIX IN HAND need r=
(Assignee)

Comment 6

17 years ago
As per kin's suggestion, the changed line will be:
var enable = insertNew ? (dialog.hrefInput.value.trimString().length > 0) : true;

Comment 7

17 years ago
r=brade
Whiteboard: FIX IN HAND need r= → FIX IN HAND

Comment 8

17 years ago
a=asa on behalf of drivers. 
(Assignee)

Comment 9

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, regression, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND

Comment 10

17 years ago
Verified on 8-30 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.