Option to disable/enable Javascript removed (hidden)

RESOLVED DUPLICATE of bug 873709

Status

()

defect
RESOLVED DUPLICATE of bug 873709
5 years ago
3 months ago

People

(Reporter: Vengelix287, Unassigned)

Tracking

26 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Sorry, but what on earth are you thinking? What do you think the ADVANCED tab really is for?  Why not simply move the checkbox to the advanced tab? That would make EVERYONE happy! 

sorry but you are speaking against yourself if you think this will help novice users, you cant make something more userfriendly by doing it more advanced. What about people buying a used computer where JS is disabled? Before, a  novice user could easily activate it again by hitting a checkbox, but now? NO WAY..they wont EVER guess how to reenable JS, NO WAY!  

DONT BE SO DAMN STUBBORN...it's not in the spirit of open source community..PLEASE GET IT BACK, *just move it to the advanced tab* and EVERYONE will be happy.

Comment 1

5 years ago
(In reply to Kenneth from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101
> Firefox/26.0 (Beta/Release)
> Build ID: 20131205075310
> 
> Steps to reproduce:
> 
> Sorry, but what on earth are you thinking?

Let me stop you right there. Here's what we were thinking: bug 851702. And then bug 873709. Which this is a duplicate of. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873709

Comment 2

5 years ago
(In reply to Kenneth from comment #0)
> What about people buying a used computer where JS is disabled?
bug 851702 automatically resets JS to enabled when upgrading from earlier than Firefox 23, and bug 498181 offers to do a profile reset (which resets JS to enabled) on profiles untouched for more than 60 days.
> Why not simply move the checkbox to the advanced tab?
bug 864249 put a checkbox in Web Developer -> Toggle Tools, "Advanced" section of per page Options since Firefox 24.
(Non-novice users can still add about:config?filter=javascript.enabled to their bookmarks for toggling the global pref)

Comment 3

5 years ago
You closed it as duplicate of a bug who has been abusively closed as "RESOLVED INVALID"

You destroyed point 5 of manifesto (https://www.mozilla.org/en-GB/about/manifesto/) : "Individuals must have the ability to shape the Internet and their own experiences on it."

No Script is an extension, and as such cannot be 100% trusted. For example, it did interfere with adblock plus.

about:config is NOT a workaround
for example how can we enable javascript and disable "move or resize popup windows".

How about ESR ? about:config is forbidden, and no extensions can be installed.
You need to log in before you can comment on or make changes to this bug.