Closed Bug 965468 Opened 7 years ago Closed 7 years ago

LoadStartDetectionRunnable doesn't actually wait for loadstart

Categories

(Core :: DOM: Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox26 --- wontfix
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

LoadStartDetectionRunnable::RegisterAndDispatch() is unused. Instead the runnable is created and dispatched manually.

Thus the loadstart listener is never added, which effectively makes it just a normal runnable as it doesn't wait for loadstart.
Comment on attachment 8367547 [details] [diff] [review]
0002-Bug-965468-Make-LoadStartDetectionRunnable-wait-for-.patch

Yikes! Thanks for finding that.
Attachment #8367547 - Flags: review?(khuey) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/acdd3135860f
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Should we try to uplift this?
https://hg.mozilla.org/mozilla-central/rev/acdd3135860f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
(In reply to Tim Taubert [:ttaubert] from comment #4)
> Should we try to uplift this?

Yeah, to aurora at least.
Comment on attachment 8367547 [details] [diff] [review]
0002-Bug-965468-Make-LoadStartDetectionRunnable-wait-for-.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 740069
User impact if declined: If have no idea.
Testing completed (on m-c, etc.): In m-c without issues so far.
Risk to taking this patch (and alternatives if risky): Seems rather low-risk to me.
String or IDL/UUID changes made by this patch: None.

Maybe bent can elaborate on issues that could be caused by not having this patch?
Attachment #8367547 - Flags: approval-mozilla-aurora?
Attachment #8367547 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.