Inconsistent UI when hovering over the Get Started button on about:accounts

RESOLVED DUPLICATE of bug 972061

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 972061
5 years ago
5 years ago

People

(Reporter: pdehaan, Assigned: zaach)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Go to "about:accounts"
2. Hover over "Get Started" (Spoiler: You shouldn't see any UI change)
3. Click the "Get Started" button.
4. On the "Create an account" page, enter an email, password, eligible COPPA year, and hover over the "Next" button. (Spoiler: You should see a UI change on the button from red to orange)

Actual results:
The button state hovers aren't consistent, and I'm guessing about:accounts welcome page is incorrect.

Expected results:
The "Get Started" button on about:accounts should have a hover state.
Not sure if this is because it seems like we're using an anchor tag for "Get Started" versus a button for the Create an Account [Next] button.
Unclear whether we should:
(a) change the <a> to a <button>
(b) tweak the main.css file to add more a.button rules (presumably here, but I'm no CSS expert: https://github.com/mozilla/fxa-content-server/blob/master/app/styles/main.css#L201)
Whiteboard: [qa+]
(Reporter)

Comment 1

5 years ago
Same w/ the "Manage" button after you've logged in and go back to about:accounts.
(Reporter)

Comment 2

5 years ago
Created attachment 8367583 [details]
Nightly_Accounts.png
Assignee: nobody → zack.carter
Status: NEW → ASSIGNED

Comment 3

5 years ago
moving component
The "Manage" button you get after going to about:accounts manually is in-product, so keeping it up to date with the remove versions you get in the sign-in flow is a bit of a pain. We don't intend to ever expose "about:accounts" to users outside of the sign-in flow, though, so I wouldn't worry about it too much.
Component: Firefox Sync: UI → Sync
Product: Mozilla Services → Firefox
(Assignee)

Comment 5

5 years ago
This is fixed with the style updates in Bug 972061.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972061
You need to log in before you can comment on or make changes to this bug.