sidebar toolbarbutton shows even when there is no sidebar to show

RESOLVED FIXED in Firefox 28

Status

defect
RESOLVED FIXED
6 years ago
5 months ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Tracking

28 Branch
Firefox 28
x86
macOS

Firefox Tracking Flags

(firefox27 wontfix, firefox28+ fixed, firefox29 unaffected, b2g-v1.3 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

[aurora] The toolbar button shows when you install a provider that does not have a sidebar.  One such provider uses only a status button, in which case two buttons appear in the toolbar, one for the status panel, one for the sidebar.  Following patch prevents showing the sidebar toolbarbutton if no sidebar providers exist.
Assignee: nobody → mixedpuppy
Attachment #8368921 - Flags: review?(felipc)
Attachment #8368921 - Flags: review?(felipc) → review+
Comment on attachment 8368921 [details] [diff] [review]
only show button when we have sidebar providers

Assuming this doesn't beat uplift, would need beta approval instead...basically need this in fx28.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): socialapi toolbarbutton
User impact if declined: a second misleading button icon for users of some providers.
Testing completed (on m-c, etc.): aurora fx28
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8368921 - Flags: approval-mozilla-aurora?
Since it hasn't landed on central yet, might need to land post-merge, I'll carry over the approval nom if necessary and tracking to ensure this lands in 28.
Comment on attachment 8368921 [details] [diff] [review]
only show button when we have sidebar providers

Cf comment #4 from Lukas and since the merge has been done, aurora does not need the uplift while it is now needed for the beta.
Attachment #8368921 - Flags: approval-mozilla-beta+
Attachment #8368921 - Flags: approval-mozilla-aurora?
Attachment #8368921 - Flags: approval-mozilla-aurora-
https://hg.mozilla.org/releases/mozilla-beta/rev/f0adf847ac2d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Whiteboard: [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.