Closed Bug 965581 Opened 6 years ago Closed 7 months ago

various one pixel errors when rendering svg shapes and lines

Categories

(Core :: SVG, defect)

26 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 608812

People

(Reporter: salomvary, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.77 Safari/537.36

Steps to reproduce:

Try to create rects, rects with one pixel stroke and one pixel lines (optionally try to make them rendered sharp).

Examples:

1. Draw a 100 by 100 rect at 100, 100.

http://jsfiddle.net/salomvary/WSHs5/
Expected (rect at proper position, no blurred edges):
https://www.dropbox.com/s/7vw76ecxqb8e8t3/Screenshot%202014-01-29%2013.58.45.png

2. Draw a rect with one pixel sharp stroke.

http://jsfiddle.net/salomvary/HV3SZ/
Expected (rect act proper position, no blurred edges when offset by half pixel):
https://www.dropbox.com/s/i9u6w1j6j7z1hmn/Screenshot%202014-01-29%2014.06.59.png

3. Draw a one pixel wide sharp line.

http://jsfiddle.net/salomvary/3BQ7D/
Expected (line at proper position, not blurred when offset by half pixel): 
https://www.dropbox.com/s/klwsm9s924aanyr/Screenshot%202014-01-29%2015.03.01.png

Environment:
OSX 10.9
non-retina MacBook Pro (13-inch, Mid 2012)


Actual results:

Results:

1. 

A rect with blurred edges and in wrong position by one pixel. 
https://www.dropbox.com/s/9tl5itajhhs5c2v/Screenshot%202014-01-29%2015.06.24.png

2. 

Blurred edges in every direction
https://www.dropbox.com/s/5od6kv075sklqcg/Screenshot%202014-01-29%2014.56.17.png
(Interestingly, without the half pixel offset the edges are much sharper, but there is still a subtle blur around the top and bottom strokes: https://www.dropbox.com/s/i1zrbjsdv4zgw6g/Screenshot%202014-01-29%2014.57.03.png)

3. 

Blurred line
https://www.dropbox.com/s/082tgqvdlmhzhu6/Screenshot%202014-01-29%2015.04.06.png
(Interestingly, without the half pixel offset the lines are sharp but the position is wrong by one pixel https://www.dropbox.com/s/nuz9uy1n8roa708/Screenshot%202014-01-29%2015.05.35.png). 



Expected results:

1. Rect in proper position without blurred edges.
2. When sharp one pixel stroke when using half pixel offset. Consistently blurred strokes when not using half pixel offset.
3. Sharp one pixel wide line when using half pixel offset. Blurred line at the proper position without the offset.
User agent of the affected version:
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0"
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608812
You need to log in before you can comment on or make changes to this bug.