Text cursor disappears in body after pressing certain toolbar buttons

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
5 years ago
4 months ago

People

(Reporter: Zach Nickell, Unassigned)

Tracking

({regression})

28 Branch
x86_64
All
regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird28?, thunderbird29?)

Details

(Whiteboard: [regression:TB28])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36

Steps to reproduce:

1. open new message window
2. click the message body
3. click either the 'Spelling' or 'Security' toolbar button
4. hit esc or close out of the dialog box
5. start typing or click the message body and start typing (same result)


Actual results:

The text cursor does not appear in the message body.  Focus is being restored to the body, but it is not apparent due to the missing cursor.


Expected results:

The text cursor should have reappeared in the message body.

Comment 1

5 years ago
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/b1e5ade62913
http://hg.mozilla.org/comm-central/rev/1f890b59ac38
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Thunderbird/29.0a1 ID:20131217030202
Bad:
http://hg.mozilla.org/mozilla-central/rev/5c7fa2bfea8b
http://hg.mozilla.org/comm-central/rev/c1bb1f98c4c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Thunderbird/29.0a1 ID:20131219030202
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b1e5ade62913&tochange=5c7fa2bfea8b
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=1f890b59ac38&tochange=c1bb1f98c4c5
Status: UNCONFIRMED → NEW
tracking-thunderbird28: --- → ?
tracking-thunderbird29: --- → ?
Ever confirmed: true
Keywords: regression
OS: Linux → All
Version: Trunk → 28

Comment 2

5 years ago
Regression window(early)
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/369bdbff6c38
http://hg.mozilla.org/releases/comm-aurora/rev/63baf8270c1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Thunderbird/28.0a2 ID:20131218004002
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/809aabadac6d
http://hg.mozilla.org/releases/comm-aurora/rev/050ad37adbd9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Thunderbird/28.0a2 ID:20131219004002
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=369bdbff6c38&tochange=809aabadac6d
http://hg.mozilla.org/releases/comm-aurora/pushloghtml?fromchange=63baf8270c1c&tochange=050ad37adbd9

Suspected:
57157e39abea	Blake Kaplan — Bug 933483 - Don't fire events (and especially request animation frame events) when we're in a modal dialog. r=smaug, a=koi+
Blocks: 933483

Updated

5 years ago
Depends on: 965690
mrbkap, if we disabled event suppression from chrome docs, for now, I think this would be fixed then too.

Comment 4

4 years ago
intended for mrbkap, but unclear ot me if this is a question for, or statement to 

(In reply to Olli Pettay [:smaug] from comment #3)
> mrbkap, if we disabled event suppression from chrome docs, for now, I think
> this would be fixed then too.
Flags: needinfo?(mrbkap)
Whiteboard: [regression:TB28]
I'm not going to get to this for a while, clearing the needinfo.
Flags: needinfo?(mrbkap)
(Reporter)

Comment 6

4 months ago
It looks like this has been fixed, I can't reproduce this bug anymore.
(Reporter)

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.