Closed Bug 965681 Opened 6 years ago Closed 6 years ago

Intermittent TEST-UNEXPECTED-FAIL : xperf: File 'c:\program files\nvidia corporation\3d vision\nvstereoapii.dll' was accessed and we were not expecting it. DiskReadCount: 4, DiskWriteCount: 0, DiskReadBytes: 33792, DiskWriteBytes: 0

Categories

(Testing :: Talos, defect)

All
Windows 7
defect
Not set

Tracking

(firefox28 fixed, firefox29 fixed, firefox30 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
mozilla30
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
firefox30 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: KWierso, Assigned: vaibhav1994)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=33786349&tree=Mozilla-Inbound
slave: t-w732-ix-119




20:56:42     INFO -  |78;orange.fr/www.orange.fr/index.html;206
20:56:42     INFO -  |79;php.net/php.net/index.html;160
20:56:42     INFO -  |80;zol.com.cn/www.zol.com.cn/index.html;653
20:56:42     INFO -  |81;mashable.com/mashable.com/index.html;630
20:56:42     INFO -  |82;etsy.com/www.etsy.com/category/geekery/videogame.html;191
20:56:42     INFO -  |83;gmx.net/www.gmx.net/index.html;719
20:56:42     INFO -  |84;csdn.net/csdn.net/index.html;532
20:56:42     INFO -  |85;xunlei.com/xunlei.com/index.html;472
20:56:42     INFO -  |86;hatena.ne.jp/www.hatena.ne.jp/index.html;593
20:56:42     INFO -  |87;icious.com/www.delicious.com/index.html;239
20:56:42     INFO -  |88;repubblica.it/www.repubblica.it/index.html;409
20:56:42     INFO -  |89;web.de/web.de/index.html;284
20:56:42     INFO -  |90;slideshare.net/www.slideshare.net/jameswillamor/lolcats-in-popular-culture-a-historical-perspective.html;240
20:56:42     INFO -  |91;telegraph.co.uk/www.telegraph.co.uk/index.html;296
20:56:42     INFO -  |92;seesaa.net/blog.seesaa.jp/index.html;1218
20:56:42     INFO -  |93;wp.pl/www.wp.pl/index.html;253
20:56:42     INFO -  |94;aljazeera.net/aljazeera.net/portal.html;577
20:56:42     INFO -  |95;w3.org/www.w3.org/standards/webdesign/htmlcss.html;221
20:56:42     INFO -  |96;homeway.com.cn/www.hexun.com/index.html;559
20:56:42     INFO -  |97;facebook.com/www.facebook.com/Google.html;96
20:56:42     INFO -  |98;youtube.com/www.youtube.com/music.html;250
20:56:42     INFO -  |99;people.com.cn/people.com.cn/index.html;460
20:56:42     INFO -  __end_tp_report
20:56:42     INFO -  __start_cc_report
20:56:42     INFO -  _x_x_mozilla_cycle_collect,4593
20:56:42     INFO -  __end_cc_report
20:56:42     INFO -  __startTimestamp1391057554167__endTimestamp
20:56:42     INFO -  __startBeforeLaunchTimestamp1391057470000__endBeforeLaunchTimestamp
20:56:42     INFO -  __startAfterTerminationTimestamp1391057556000__endAfterTerminationTimestamp
20:56:42     INFO -  DEBUG : Terminating: firefox, plugin-container, crashreporter, dwwim
20:56:44     INFO -  ;web.de/web.de/index.html;284
20:56:44     INFO -  |90;slideshare.net/www.slideshare.net/jameswillamor/lolcats-in-popular-culture-a-historical-perspective.html;240
20:56:44     INFO -  |91;telegraph.co.uk/www.telegraph.co.uk/index.html;296
20:56:44     INFO -  |92;seesaa.net/blog.seesaa.jp/index.html;1218
20:56:44     INFO -  |93;wp.pl/www.wp.pl/index.html;253
20:56:44     INFO -  |94;aljazeera.net/aljazeera.net/portal.html;577
20:56:44     INFO -  |95;w3.org/www.w3.org/standards/webdesign/htmlcss.html;221
20:56:44     INFO -  |96;homeway.com.cn/www.hexun.com/index.html;559
20:56:44     INFO -  |97;facebook.com/www.facebook.com/Google.html;96
20:56:44     INFO -  |98;youtube.com/www.youtube.com/music.html;250
20:56:44     INFO -  |99;people.com.cn/people.com.cn/index.html;460
20:56:44     INFO -  __end_tp_report
20:56:44     INFO -  __start_cc_report
20:56:44     INFO -  _x_x_mozilla_cycle_collect,4593
20:56:44     INFO -  __end_cc_report
20:56:44     INFO -  __startTimestamp1391057554167__endTimestamp
20:56:44     INFO -  extending with xperf!
20:56:44     INFO -  The trace you have just captured "C:\slave\test-pgo\build\test.etl.kernel" may contain personally identifiable information, including but not necessarily limited to paths to files accessed, paths to registry accessed and process names. Exact information depends on the events that were logged. Please be aware of this when sharing out this trace with other people.
20:56:44     INFO -  The trace you have just captured "C:\slave\test-pgo\build\test.etl.user" may contain personally identifiable information, including but not necessarily limited to paths to files accessed, paths to registry accessed and process names. Exact information depends on the events that were logged. Please be aware of this when sharing out this trace with other people.
20:56:44     INFO -  Merged Etl: test.etl
20:56:44     INFO -  c:/Program Files/Microsoft Windows Performance Toolkit/xperf: warning: applying restriction of access for trace processing
20:56:44     INFO -  reading etl filename: test.etl
20:56:44     INFO -  etlparser: in readfile: test.etl.csv
20:56:44     INFO -  TEST-UNEXPECTED-FAIL : xperf: File 'c:\program files\nvidia corporation\3d vision\nvstereoapii.dll' was accessed and we were not expecting it.  DiskReadCount: 4, DiskWriteCount: 0, DiskReadBytes: 33792, DiskWriteBytes: 0
20:56:44     INFO -  Detected a regression for tp5n:
20:56:44     INFO -  		Stopped Wed, 29 Jan 2014 20:56:44
20:56:44    ERROR - Return code: 1
aklotz: this is more random vs a regular occurrence, any idea why we would be accessing this?  I assume something landed yesterday that would have caused this file to be accessed.
Flags: needinfo?(aklotz)
https://tbpl.mozilla.org/php/getParsedLog.php?id=33816761&tree=Fx-Team
Summary: Intermittent TEST-UNEXPECTED-FAIL : xperf: File 'nvstereoapii.dll' was accessed and we were not expecting it. DiskReadCount: 4, DiskWriteCount: 0, DiskReadBytes: 33792, DiskWriteBytes: 0 → Intermittent TEST-UNEXPECTED-FAIL : xperf: File 'c:\program files\nvidia corporation\3d vision\nvstereoapii.dll' was accessed and we were not expecting it. DiskReadCount: 4, DiskWriteCount: 0, DiskReadBytes: 33792, DiskWriteBytes: 0
I examined one of the .etl files for these oranges.

According to the callstack, the last xul.dll entry was mozilla::layers::LayerManagerD3D10::Initialize. It's probably something to do with the initialization of Nv3DVUtils.
Flags: needinfo?(aklotz)
With https://tbpl.mozilla.org/?tree=Try&rev=5bed8cd17170 I ran a whole bunch of xperf tests on m-c 165049:b21ef8cb0db6, dated Jan 24 11:59:00 PST.

Most of the xperf tests were green, but then they hit a wave of oranges.

Given the age of the revision that I tested with is a few days older than when we started initially seeing the oranges on inbound and fx-team, it is unlikely that these problems are due to a code change.

Having said that, I then looked at the IDs of the slave machines used in these tests to determine if there was a pattern there. The sets of green and orange slaves in my try run were disjoint.

OTOH, when I include Joel's try run from https://tbpl.mozilla.org/?tree=Try&startdate=2014-01-28&enddate=2014-01-30&rev=2dff7c9943d1, the greens from my try run intersect with some of the oranges from his try run. So the oranges are not being repeatedly, consistently returned by the same slave machines.
Can I take up this bug?
Assignee: nobody → vaibhavmagarwal
Attached patch xperf.patchSplinter Review
Attachment #8370055 - Flags: review?(jmaher)
Comment on attachment 8370055 [details] [diff] [review]
xperf.patch

Review of attachment 8370055 [details] [diff] [review]:
-----------------------------------------------------------------

looks great, thank!
Attachment #8370055 - Flags: review?(jmaher) → review+
landed:
https://hg.mozilla.org/build/talos/rev/5c0e8aef4a49
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
leaving this open until we get the talos update on m-c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 968095
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.