Firefox mishandles JPG-images rotated with MS Paint

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: mvdejong, Unassigned)

Tracking

26 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I have taken a picture with my Olympus SZ-31MR compact camera.  For proper display, this image needed to be rotated to display in portrait-format, and usually I do this with ArcSoft PhotoStudio 5.5.0.87, without issues.  On another system, where PhotoStudio wasn't available, I recently used the MS Paint-program as included with MS Vista, version 6.0, build 6002, SP2.  I also tested it with the MS Paint version 6.1, build 7601, SP1 as included with Windows 7.


Actual results:

When opening up the PhotoStudio-version with Firefox (currently version 26.0), the image is display properly.
When opening up the Paint-version, the image is distorted.  Whereas the image is in portrait-format, the contents are not displayed rotated, but are stretched vertically and compressed horizontally to fit into the displayed format.

Interestingly, when using the mobile version of FireFox on my HTC One X, Android 4.2.2, the Paint-version displayed in landscape-format, but rotated 180 degrees.  I might report that separately, but it seems that there is an underlying problem common to both versions.


Expected results:

The image should display properly, and all other tools I've used to view the image do so (including IE).  It happens with all JPG-files I rotated using MS Paint.  It still may be a problem in the way MS Paint handles the storage of a rotated file, but FireFox seems the only program affected by it (of course, Firefox may be the only program handling JPG-images correctly).

The images :
http://www.mvdejong.luna.nl/FireFoxTest-original.jpg
http://www.mvdejong.luna.nl/FireFoxTest-PhotoStudio.jpg
http://www.mvdejong.luna.nl/FireFoxTest-Paint.jpg
(Reporter)

Comment 1

4 years ago
A recent update of FireFox changed the behaviour, now the images that were rotated with MS Paint are displayed as if they were not rotated at all.

Comment 2

3 years ago
Works for me, in Firefox 37.0.1 and Nightly 40.0a1 (2015-04-06) on Windows 7.

Please test the latest Nightly in a brand new profile. If you can still reproduce the problem, post a reply so this report can be reopened.
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.