Closed Bug 965772 Opened 6 years ago Closed 6 years ago

search text box changes size when opening a new tab

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: bhearsum, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

The width of the search box changes when I open a new tab, and sometimes under other circumstances that I haven't nailed down. I bisected this to https://tbpl.mozilla.org/?rev=128c86a925d7 (https://hg.mozilla.org/mozilla-central/pushloghtml?startID=26096&endID=26097)

Bugs 941409 and 962844 look most suspect.
Bug 962844 has changes to the search and urlbar size so is likely the cause.
I think this happens only in profiles where the location and search bars haven't been resized manually.
Assignee: nobody → dao
Blocks: 962844
Component: Search → General
OS: Linux → All
Hardware: x86_64 → All
Keywords: regression
Attached patch patchSplinter Review
I don't understand exactly how layout works here, but this seems to fix it for me.
Attachment #8367955 - Flags: review?(enndeakin)
Comment on attachment 8367955 [details] [diff] [review]
patch

Not sure I'm the right reviewer here, but it seems ok. Is the min-width on #search-container what is keeping it at a suitable default width?
Attachment #8367955 - Flags: review?(enndeakin) → review+
The default width comes mainly from the flex attributes (100 for the search bar, 400 for the location bar), but it seems that the XUL layout tries to be smart and adjusts the width depending on the location bar's content, hence this bug. My guess is that setting width attributes (like we do when resizing the bars) or both a CSS width and min-width (setting only one of the two didn't seem to help) prevents XUL layout from being too smart.
https://hg.mozilla.org/mozilla-central/rev/f7c6b8b1caf7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Duplicate of this bug: 966158
Depends on: 970020
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

Verified fixed on Firefox 29 beta 6 (build ID: 20140407135746).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.