Devtools color picker not present when !important is given

VERIFIED DUPLICATE of bug 947733

Status

DevTools
Inspector
VERIFIED DUPLICATE of bug 947733
5 years ago
a month ago

People

(Reporter: Peter Kroon, Unassigned)

Tracking

29 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140130030202

Steps to reproduce:

Go to: http://www.mozilla.org/en-US/
Inspect "We are" h1 tag
Changed value color property to: #C13832 !important


Actual results:

Color picker did not show up


Expected results:

Color picker should be present.
When  !important is given in the value the color picker will not show up.

Updated

5 years ago
Component: Untriaged → Developer Tools: Inspector
Component: Developer Tools: Inspector → Layout: Form Controls
Product: Firefox → Core
[Sorry, I assumed this was <input type="color">-related and blindly reclassified. --> Updating summary and moving back to devtools for the time being.]
Component: Layout: Form Controls → Developer Tools: Inspector
Product: Core → Firefox
Summary: color picker not present when !important is given → Devtools color picker not present when !important is given
I can't reproduce. Peter (or anyone else who can reproduce), perhaps you could attach a screencast or provide more detailed steps to reproduce?

Also, here's a simpler testcase:
 data:text/html,<div style="height: 100px; width: 100px; background: purple !important">

With that testcase, as well as at mozilla.org with the "#C13832 !important" tweak, I can trigger the colorpicker by clicking the little colorful circle next to the CSS value.

(In reply to Peter Kroon from comment #0)
> Firefox/29.0 (Beta/Release)

(aside: this is an odd version of Firefox, since version 29 hasn't hit Beta/Release yet. ;) I take this to mean you're using a custom Firefox build. It's possible (though probably unlikely) that this bug might be caused by one of the modifications in that build.)

Comment 3

5 years ago
(In reply to Daniel Holbert [:dholbert] from comment #1)
> [Sorry, I assumed this was <input type="color">-related and blindly
> reclassified. --> Updating summary and moving back to devtools for the time
> being.]

Yes indeed, doesn't sound like it's related to input type color; devtools use their own color picker, as per bug 889638 if I'm right (if so, probably worth to make this bug as "depends on" bug 889638 to reference it).

Btw, bug 889638 was implement while we were working input type color wasn't finished yet. Maybe worth to use input type color instead in devtools now it is? Not sure since devtools' color picker is really nice and easy to use and might be better for this need (i.e. quickly pick another color).

Daniel, what do you think?
(maybe better to discuss this in bug 889638 though).
(Reporter)

Comment 4

5 years ago
Created attachment 8369450 [details]
Screencast

per request
(Reporter)

Comment 5

5 years ago
Just uploaded a screencast and on linux no devtools color picker is present.
UA: "Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0"

> Firefox/29.0 (Beta/Release)

>(aside: this is an odd version of Firefox, since version 29 hasn't hit Beta/Release yet. ;) I take this to mean you're >using a custom Firefox build. It's possible (though probably unlikely) that this bug might be caused by one of the >modifications in that build.)

I'm not using any kind of custom build on my winbdows 7 32 bit system.
On my windows system I have installed  latest: FireFox, Firefox BETA, Aurora, Nightly.
Thanks for the screenshot (and thanks for the custom-build clarification. "29 Beta/Release" still seems odd, but maybe that's a Bugzilla form-autofill quirk, or something Windows-specific)

So from some quick testing on my machine, it looks to me like the devtools colorpicker is not there *at all* in the Release version of Firefox (v26), on my Linux machine at least, which explains comment 5's screencast behavior. (no colorpicker at all)

Also: when I came in to the office a few minutes ago, I was initially able to reproduce this bug in my (out-of-date, last-updated-last-week) Nightly build. But then I restarted Firefox to install updates, and now I can't reproduce. (i.e. I now see a colorful dot when I load my data URL from Comment 2 in Nightly & inspect the rect.)

So perhaps this was fixed in another bug?  Peter,
*Peter, would you mind trying the latest Nightly build? (Mine says "29.0a1 (2014-02-03)" in Help | About)
Yeah, actually, it looks like this is almost certainly a duplicate of bug 947733 (whose fix landed on 1/30; so, it looks like you were unlucky enough to file this the *day* before it was fixed. :))

Thanks for the bug report, though! And if you can still reproduce in up-to-date nightlies, please do mention that here so we can dig deeper.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947733
(In reply to Arnaud Bienner from comment #3)
> Daniel, what do you think?
> (maybe better to discuss this in bug 889638 though).

(I don't have strong feelings about it.)
(Reporter)

Comment 10

5 years ago
(In reply to Daniel Holbert [:dholbert] from comment #7)
> *Peter, would you mind trying the latest Nightly build? (Mine says "29.0a1
> (2014-02-03)" in Help | About)

Works like a charm on my windows sytem.
Current nightly: 29.0a1 (2014-02-03)
Great, thanks for confirming!
Status: RESOLVED → VERIFIED

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.