Open Bug 966057 Opened 6 years ago Updated 3 years ago

Lag in menu Ubuntu server 10 32 bits

Categories

(Firefox :: Menus, defect)

26 Branch
x86
Linux
defect
Not set

Tracking

()

People

(Reporter: guigs, Unassigned, NeedInfo)

Details

(Keywords: perf)

Hi there is a screencast of this lag and is reproducible on multiple profiles and computers. 
This one may also be related to this but was resolved by updating the OS
Bug 477068 - Context menu and drop down list are slow to appear when running on Linux Terminal Server Project (remote X) (edit) 

Ref[https://support.mozilla.org/en-US/questions/983670?]

Setup: Ubuntu 10 64 bits

2. Happens on a single computer, note that all my other computers are 32 bits except for a Windows 7 64 bits
3. Pretty much any menu click or right click has a lag which is variable, but still important.
4. Try Developer tools: console, below is an example of a right click. You can see a lag between seconds 44 and 48, but I don't see any meaningful error message (the ones that are there are unrelated to me, meaning that I reproduce the issue without the messages).
GET http://dis.criteo.com/pump/match.aspx [HTTP/1.1 200 OK 121ms]
23:57:44.274 GET http://image2.pubmatic.com/AdServer/Pug [HTTP/1.1 200 OK 136ms]
23:57:44.274 GET http://atemda.com/UserMatch.ashx [HTTP/1.1 200 OK 153ms]
23:57:44.274 GET http://ums.adtech.de/mapuser [HTTP/1.0 200 OK 93ms]
23:57:44.275 GET http://d.turn.com/r/dd/id/L2NzaWQvMS9jaWQvMTgxMzE0MzAvdC8w/url/http%3a%2f%2fc1.adform.net%2fserving%2fcookie%2fmatch%2f%3fparty%3d1006%26cid%3d%24!%7bTURN_UUID%7d [HTTP/1.1 302 Moved Temporarily 109ms]
23:57:44.261 Expected declaration but found '*'. Skipped to next declaration. eventi-feste-25
23:57:44.261 Unknown property 'zoom'. Declaration dropped. eventi-feste-25
23:57:44.264 Error in parsing value for 'left'. Declaration dropped. eventi-feste-25
23:57:44.265 Error in parsing value for 'top'. Declaration dropped. eventi-feste-25
23:57:48.537 GET http://s1.adform.net/Banners/2380469/2380469.gif [HTTP/1.1 200 OK 260ms]
23:57:48.538 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 146ms]
23:57:48.871 GET http://static.bakeca.it/be/public/css/img/footer_background.png [HTTP/1.1 200 OK 46ms]
23:57:48.873 GET http://static.bakeca.it/be/public/css/img/feed_s.gif [HTTP/1.1 200 OK 51ms]
23:57:48.874 GET http://static.bakeca.it/be/public/css/img/fb1.gif [HTTP/1.1 200 OK 55ms]
23:57:48.874 GET http://static.bakeca.it/be/public/css/img/tw.gif [HTTP/1.1 200 OK 60ms]
23:57:48.875 GET http://static.bakeca.it/be/public/css/img/logo_footer.png [HTTP/1.1 200 OK 493ms]
23:57:48.875 GET http://pubads.g.doubleclick.net/gampad/ads [0ms]
23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 88ms]
23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 68ms]
23:57:49.181 GET https://track.adform.net/Serving/TrackPoint/
23:57:49.181 GET https://secure.adnxs.com/seg
23:57:49.182
Debugger does not seem to report anything special.

I have attached a screencast where I perform a right click, then go into the button menu.
You can find it on dropbox
https://dl.dropboxusercontent.com/u/95778517/inquire983670.ogv

Steps to produce:
Summary: Lag in menu → Lag in menu Ubuntu server 10 32 bits
rmcguigan,
have you seen this in recent versions?
Flags: needinfo?(rmcguigan)
Keywords: perf
You need to log in before you can comment on or make changes to this bug.