If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

moz fails to reload images properly using squid proxy and shift+reload

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Jeremy Sanders, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    

Using 0.9.3 moz on linux, with a squid proxy Squid/2.4.STABLE1, when I
shift+reload the bbc news site http://news.bbc.co.uk/ , some or all of the
images fail to reload. The moz throbber continues to animate, but the page never
completes loading.

They reload (quite slowly) if a direct connection is used.


Reproducible: Always
Steps to Reproduce:
1. Go to http://news.bbc.co.uk/
2. Click shift+reload
3.

Actual Results:  Some of the images fail to reload. The page never completes
loading.


Expected Results:  Page should load completely.

Netscape 4 works fine in this setup. Using http 1.0 doesn't help in mozilla.

Comment 1

16 years ago
Reporter, I'm using Squid myself locally on 2001083108, and I can't reproduce
this with that website at all.I shift-click and all images load nicely. There is
a fair amount of white flashing over the right-hand bulletins while the images
load, but after 20s or so the page loads completely.

Please try a current build and test again, please.
(Reporter)

Comment 2

16 years ago
The bug appears fixed in Gecko/20010831

Comment 3

16 years ago
Resolving WFM based on reporter's feedback. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
reporter:

This bug is a "futured" or "untargeted" bug which has been "resolved/works for
me". Most bugs meeting this criteria are usually somewhat out of date or working
in the current builds.

If this bug is not happening for you in a recent build (such as the Mozilla
daily build, Mozilla 0.9.3, or Netscape 6.1), please use the friendly "Mark bugs
as VERIFIED" radio button to set this bug to "VERIFIED/WORKS FOR ME"
If you reported the bug on a platform (e.g. Linux) and other contributors
reported on another platform (e.g. Mac OS), please comment that it works for you
 but do not verify it yet.

For these multi-platform bug reports, we need to verify all reported platforms
-OR- create new "still broken on platform X" bugs when you verify.
(Reporter)

Comment 5

16 years ago
As earlier comment says, this bug doesn't occur in recent builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.