Make web search configurable from Options

RESOLVED FIXED in Thunderbird 38.0

Status

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: step247, Assigned: squib)

Tracking

24 Branch
Thunderbird 38.0
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206145143

Steps to reproduce:

Make search configurable and REMOVE! f'n Bing from a default search engine. 

I can not believe that I am forced to use that **** Microsoft's search and it's only f'n option available. To get any other search engine, I have to start installing f'n plugins!?



Expected results:

What should have happened?
Users should have a option to select the search engine they like and not be forced to use any **** form Microsoft.
ref: bug 731590, https://support.mozillamessaging.com/en-US/kb/open-search#w_how-to-change-the-default-search-engine  etc

FWIW ... statement B. REMOVE bing as default search engine isn't going to happen. If you want this bug to fly, you'll want to focus entirely on A. Make search [more] configurable ... such as Firefox's "Configure Search Engines".
If you're interested in improving the configurability of the search providers, I recommend taking a look at bug 335781.
I agree users should have the option to select a search engine without having to muck around in their profile directory with XML files. If the search engine list was made configurable through a respectable user interface, I'd stop caring that Bing is the default. 

To that end, NameReal, please do visit bug 335781 and hit "Vote" under the 'Importance' field. Possibly add yourself to the CC list. That bug has the most momentum and progress is being made (if slowly).
Is there a reason why this can't even be configured to go away by advanced users in the Config Editor. There seems no way to make this superfluous UI element go away. 

(The only way I found was to install Little Snitch and add Bing to the blocked URLs (hey that's a good reason to leave Bing as the default - because then you can block Bing at the firewall, while if it was <insert your favorite searchengine> that wouldn't work. 

But seriously - come on, if there is a commercial reason that Bing gets first preference as Search engine and cannot be changed nor the item listed then in the interests of transparency please state it.
There's nothing stopping you from changing the default search engine right now. Just perform a search and then click one of the search engines on the left. Then click the little heart at the bottom to make it your preferred/favorite search engine. Subsequent searches will default to using that engine.

If you really want, say, Google search, you can add the Google search provider from here: https://addons.mozilla.org/en-US/thunderbird/addon/google-search-for-thunderbi/

All of this, of course, is suboptimal, but that's why we should push for bug 335781, since that will help configuration enormously.
Repurposing this bug a bit...
Assignee: nobody → squibblyflabbetydoo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Make search configurable and REMOVE! Bing as default option → Make web search configurable from Options
Posted patch set-websearch.patch (obsolete) — Splinter Review
Ok, here's a simple patch for this. We might want to add UI for adding your own favorite search engine, but that's kind of complex, since I think you currently need to write an add-on to add a custom engine to TB. I'm not 100% sure how we should fix that.
Attachment #8543126 - Flags: ui-review?(josiah)
Attachment #8543126 - Flags: feedback?(mkmelin+mozilla)
Comment on attachment 8543126 [details] [diff] [review]
set-websearch.patch

Review of attachment 8543126 [details] [diff] [review]:
-----------------------------------------------------------------

Initially the dropdown was tiny (like for only a "" value), but I can't reproduce anymore... 
Otherwise looks ok, though it's a bit of a prominent place for something so little used.

Thinking about the context menu, I wonder if we should have a default at all. It would be way more useful to have it as a popup with engine selection. The it would actually be useful for something. Sometimes you want to look up something from wikipedia, sometimes look for an item on amazon, sometimes twitter. But you really can't say beforehand, so there's no useful default in that regard.

----------------------------  -----------
Search the web for "mozilla" > Bing
----------------------------   Wikipedia
                               eBay
                               Amazon
                               ....
                              -----------
                               
Sure it's a bit further away, but it'd still be more useful.
Attachment #8543126 - Flags: feedback?(mkmelin+mozilla)
I absolutely think there should be some default (although the menu item could be a dual-button that still lets you pick the engine if you click the arrow). 99% of the time, I just want to search with Google (substitute Bing or DDG depending on personal taste).
Also, my main goal here is just to replicate the behavior of the engine selection from the web search tab (since I plan on removing that tab). I'd certainly like to improve it further, but for now, we just need something that doesn't regress features.
(In reply to Magnus Melin from comment #8)
> Initially the dropdown was tiny (like for only a "" value), but I can't
> reproduce anymore... 

I see that for about a second on the first launch of the Prefs dialog (because the list of search engines is fetched asynchronously). I suppose I could hide the widget until it's loaded, but I'll wait for Josiah to chime in on what the UX should be like.
Comment on attachment 8543126 [details] [diff] [review]
set-websearch.patch

Review of attachment 8543126 [details] [diff] [review]:
-----------------------------------------------------------------

I think it's fine really. Let's move it up so it's under the Daily Start Page section. It would look less strange that way.

Also, yeah, the fact that it's not loaded on initial launch is a problem (Doesn't affect in-content prefs though :))

Once those changes are made ui-r+. No need to over complicate this since we're removing it from global box search anyway (Bug 923656).
Attachment #8543126 - Flags: ui-review?(josiah) → ui-review+
This moves the widget so it's below the Start Page section.

I still don't see the issue with this not loading properly; I've tried on a new profile and my existing profile, and it works in all cases for me.
Attachment #8543126 - Attachment is obsolete: true
Attachment #8566231 - Flags: ui-review+
Attachment #8566231 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8566231 [details] [diff] [review]
set-websearch.patch v2

Review of attachment 8566231 [details] [diff] [review]:
-----------------------------------------------------------------

I don't see the search engine icons when expanding the dropdown (like in firefox). But looks good otherwise.
Attachment #8566231 - Flags: review?(mkmelin+mozilla) → review+
Landed: https://hg.mozilla.org/comm-central/rev/d3380f10946c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
You need to log in before you can comment on or make changes to this bug.