Closed Bug 966298 Opened 11 years ago Closed 8 years ago

Firefox Accounts (Get started UI) - Links don't preserve style after being opened

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

Firefox 29
ARM
Android
defect
Not set
normal

Tracking

(firefox29 affected, fennec-)

RESOLVED WONTFIX
Tracking Status
firefox29 --- affected
fennec - ---

People

(Reporter: ioana.chiorean, Assigned: nalexander)

Details

Attachments

(2 files)

Device: Galaxy Nexus 
OS: Android 4.3
Build: Nightly 01/31

Steps: 
1. Go to settings - Accounts - Add new Firefox Account
2. In the screen Get started - tap on the link Using an older version of Sync?
3. After reading - Go to home or put app in the background
4. Go to the Settings Sync again 

Expected results:
- the text "Using an older version of Sync?" should be still Linkified 

Actual result:
- there is no link behind the text

Note:
- same thing happens for ToS and PN links ( from second screen after the account creation)
Attached image screeshots
tracking-fennec: --- → ?
(In reply to Ioana Chiorean from comment #0)

> Expected results:
> - the text "Using an older version of Sync?" should be still Linkified 

Cannot reproduce. (Tried Home, app switcher, and Back to return to "Get started").


> - same thing happens for ToS and PN links ( from second screen after the
> account creation)

Cannot reproduce, but this activity won't be visible after Bug 966174.
I am able to reproduce this - I did try on second screen after having configured a new account. 
It is harder to get it - I remember on Friday was all the time at a first time. Now I get the non linked text after trying twice the switch open link - go to settings

Additional steps:
Go to settings - Accounts - Firefox - Configure Sync 

See video: https://www.youtube.com/watch?v=ZCz-qpqCxe4
Wow, that's a strange one.  Thanks for the video, we'll have to look into it.  Clearly something with our onCreate/onResume flow is off, I just can't think for the life of me what!
Oh, Android!
Assignee: nobody → nalexander
tracking-fennec: ? → 29+
Is still an issue on 29?
Flags: needinfo?(ioana.chiorean)
Attached image Screenshot 29.0b1
Yes,
I am able to reproduce this with 29.ob1 .
Flags: needinfo?(ioana.chiorean)
Pls. renom for tracking if this becomes a major issue. We want to fix this, but won't block Fx29/Fx30.
tracking-fennec: 29+ → -
This is no longer valid since the native Firefox Accounts UI has been removed from Fennec: Bug 1220892.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: