Yahoo TV does not trigger any notification about Flash being disabled

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
I have plugin.state.flash set to 1.

When I go to:

http://tv.yahoo.com/primetime/lopez-emotional-over-idol-reunion-050205478.html

I get no notifications about flash (no notification bar, no doorhanger).

I should get some indication that I need to enable flash,

Comment 1

5 years ago
Can you provide a screenshot? Note that if there is any visible Flash on the page, we won't show the infobar. For me, there is a Flash ad visible on the page.
Assignee: benjamin → nobody
Component: Plugin Click-To-Activate Whitelist → Plug-ins
Flags: needinfo?(mozilla)
Product: Firefox → Core
(Reporter)

Comment 2

5 years ago
Created attachment 8368698 [details]
Screenshot of problem

The problem is that you don't get the plugin box asking to enable the plugin.

So to a user, it just looks like the video didn't load (the circle keeps spinning).

If you click on the circle, you get the ask, but a user wouldn't necessarily know to do that.
Flags: needinfo?(mozilla)
(Reporter)

Comment 3

5 years ago
To be clear, I scrolled through the whole page and looked around and nowhere did I see the "click here to enable flash" box.

All I see is the spinning circle in the middle.

Comment 4

5 years ago
Created attachment 8368739 [details]
WFM, I can see Notification Bar

http://hg.mozilla.org/mozilla-central/rev/5e0a22097bff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140131030203
(Reporter)

Comment 5

5 years ago
I just did a new profile, nightly on Windows and I do not get the notification bar.

Steps were:

New profile.
Change plugin.state.flash to 1.
Go to the Yahoo TV website.
Spinning circle, no notification bar, no other flash on page.

This was a 1/28 windows nightly.
(Reporter)

Comment 6

5 years ago
Sane result with 1/31...
I do see in-page overlays, but for one load of the site only the lowermost right-side ad (outside of the current scroll view) was Flash and visible, so it's not obvious.
I wonder if we could just show the notification bar if there is at least one invisible CTP element, given that IMO ads are usually visible?

Comment 8

5 years ago
We could, but I really don't want to. You could basically force the infobar to appear by hiding a plugin somewhere, and I don't want that.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 9

5 years ago
I am going to file a separate bug about scroll positioning messing up the hidden-plugin algorithm: we're comparing coordinates with different origins which might affect this especially on slower connections.
(Reporter)

Comment 10

5 years ago
So is the rule that if the plugin is not visible to the user (as in scrolled off screen) we show the info bar? Or if it is not on the web page at all?

Comment 11

5 years ago
It should be if it is not visible on at all. I think there may be a bug especially WRT iframes.
You need to log in before you can comment on or make changes to this bug.