[FOCUS/ACT] Input widget appears to have focus but doesn't

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: danielpeng, Assigned: saari)

Tracking

Trunk
mozilla0.9.5
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Set the attached testcase as your homepage and start Mozilla 0.9.3.  The file
has Javascript that should set the focus to the text input, and, indeed, it
looks like it does; the cursor starts blinking in the text input widget.  Sadly,
if you try typing, the text doesn't go into the widget.  Curiously, Google's
homepage contains slightly different JavaScript that actually succeeds in
setting the focus in the widget.

If you hit Open New Window, you will observe the same problem.

I think this bug should probably be split, but I'm not quite sure how.* Mozilla
should open new windows with the focus in the HTML area. (keyboard scrolling
shortcuts don't work with new windows either)
* The text input widget's cursor shouldn't blink if it doesn't actually have focus.
* Javascript Issue?  Google's Javascript and the testcase's Javascript should be
functionally identical.
(Reporter)

Comment 1

17 years ago
Created attachment 46886 [details]
Test Case

Comment 2

17 years ago
->saari
Assignee: trudelle → saari
(Assignee)

Comment 3

17 years ago
appears to work okay on win32, is this linux only?
Target Milestone: --- → mozilla0.9.5

Comment 4

17 years ago
Test case and google works for me on Linux 2001083016 using click or Open in new
window.
(Reporter)

Comment 5

17 years ago
*mutter*

That's annoying.  And frustrating.

I can't reproduce the bug myself anymore after finangling my preferences a bit.

If I can figure out how to reproduce it I'll reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verify for now. Reopen if you have it again. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.