Use Cu.cloneInto() instead of ObjectWrapper.jsm

RESOLVED FIXED in 1.3 C3/1.4 S3(31jan)

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: fabrice, Assigned: fabrice)

Tracking

(Blocks: 1 bug)

unspecified
1.3 C3/1.4 S3(31jan)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8368872 [details] [diff] [review]
remove-object-wrapper.patch

The only remaining users of the jsm are the settings api files that use getObjectKind.

Baku, I never used the cloneFunctions flag - I don't think we ever supported or used that with the js version.
Attachment #8368872 - Flags: review?(amarchesini)
Comment on attachment 8368872 [details] [diff] [review]
remove-object-wrapper.patch

Review of attachment 8368872 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8368872 - Flags: review?(amarchesini) → review+
Blocks: 966526
https://hg.mozilla.org/mozilla-central/rev/018e88543710
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
Duplicate of this bug: 966916
Comment on attachment 8368872 [details] [diff] [review]
remove-object-wrapper.patch

Review of attachment 8368872 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/nfc/nsNfc.js
@@ +276,5 @@
>      let peerEvent = (NFC_PEER_EVENT_READY === evt) ? "peerready" : "peerlost";
>      let detail = {
>        "detail":sessionToken
>      };
> +    let event = new this._window.CustomEvent(peerEvent, this._wrap(detail);

Missed ')' at the end of line here and causes bug 968063.
You need to log in before you can comment on or make changes to this bug.