Closed Bug 966509 Opened 7 years ago Closed 7 years ago

wrong stacking of 3D-transformed elements

Categories

(Core :: Graphics, defect)

28 Branch
x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox27 --- unaffected
firefox28 --- verified
firefox29 --- verified
firefox30 --- verified

People

(Reporter: fb+mozdev, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

1. Goto URL
2. Goto slide 7 (with the CSS/DOM slinky) using the right-arrow key (needs quite some key presses to get there). 
3. Play through the different views/animations on slide 7 with the right-arrow key.
4. Watch what happens with the slinky's rings: some are drawn above others while they should actually not. This is mostly good during transitions/animations but most of the time breaks when animation completed. 

See attached screenshot (I have highlighted some parts of the screenshot).
Attached image garbled slinky
The slinky can get totally garbled, I saw this during mozregression around 2013-12-05 to 2013-12-15, iirc. Don't know if this is a separate issue, if this has been fixed now, so if anybody notices anything like that in later versions, please comment or file a new bug.
Last good nightly: 2013-12-07
First bad nightly: 2013-12-08

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=42b2a2adda8f&tochange=edac8cba9f78


Graphics:

Device ID	0x 166
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Vendor ID	0x8086
WebGL Renderer	Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
windowLayerManagerRemote	true
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
See Also: → 966519
See Also: → 966527
(In reply to Florian Bender from comment #3)
> Last good nightly: 2013-12-07
> First bad nightly: 2013-12-08
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=42b2a2adda8f&tochange=edac8cba9f78

Probably bug 947467, then.
Blocks: 947467
Is this fixed now? I can't reproduce it.
I was able to reproduce some obvious problems here in the latest nightly, although they might look a little different from the attached screenshots.
This issue seems fixed, at least the testcase renders fine. There's still a slight issue with (partially) hidden elements, but that's not part of this bug. 

Any idea which bug fixed this?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
fix range
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c150845d077d&tochange=1f170f9fead0
although this conflicts with comment 6, so I'm confused.
Bug 952011 in that range looks likely.
You need to log in before you can comment on or make changes to this bug.