Closed Bug 966560 Opened 8 years ago Closed 8 years ago

HAWK.signCertificate error preventing log in from working

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: Gavin, Assigned: jedp)

References

Details

(Whiteboard: [qa+])

Attachments

(1 file, 1 obsolete file)

Trying to log in generates:

1391211820029	FirefoxAccounts	ERROR	HAWK.signCertificate error: {"code":401,"error":"Unauthorized","message":"Payload is invalid","info":"https://github.com/mozilla/fxa-auth-server/blob/master/docs/api.md#response-format","errno":109,"log":[{"op":"server.onRequest","rid":"1391211819604-21542-27427"},{"op":"server.onRequest","rid":"1391211819604-21542-27427","path":"/v1/certificate/sign"}]}

Chris and Jed are debugging.
Comment on attachment 8368969 [details] [diff] [review]
0001-fix-bugs-with-time-skew-fix-in-bug-957863.patch

Review of attachment 8368969 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome.  Thanks, Chris.
Attachment #8368969 - Flags: review?(jparsons) → review+
Assignee: nobody → ckarlof
We had a duplicate now method (!), and more subtly missed a necessary test to see if 'this.internal' exists, which it only does in testing.  Reaching a point of diminishing returns on these testing mocks ...
Assignee: ckarlof → jparsons
Attachment #8368969 - Attachment is obsolete: true
Attachment #8369011 - Flags: review?(ckarlof)
No longer depends on: 966576
Duplicate of this bug: 966576
Attachment #8369011 - Flags: review?(ckarlof) → review+
https://hg.mozilla.org/mozilla-central/rev/9003e6d7c532
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.