Closed Bug 966622 Opened 7 years ago Closed 7 years ago

[contacts] import hangs at N-1 of N contacts imported from.vcf file on memory card/sd card

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S1 (14feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: aryx, Assigned: gtorodelvalle)

References

Details

(Keywords: regression, Whiteboard: burirun1.3-3)

Attachments

(4 files)

Boot2Gecko 1.3.0.0-prerelease 20140201010002 on Keon

This bug is similar to bug 962215, but its fix didn't help in this case.

When trying to import a .vcf file from the memory card, the import gets stuck at N - 1 of N contacts imported. Unfortunately, the contacts are personal, so I can't share them.
I tried to create a reduced testcase, but e.g. after splitting off a chunk of 94 contacts and trying to import only these, it gets already stuck 90 contacts.
blocking-b2g: --- → 1.3?
Is this specific to the vcf format?

Is this a regression?

There doesn't seem enough info for blocking.
Flags: needinfo?(archaeopteryx)
Keywords: qawanted
(In reply to Preeti Raghunath(:Preeti) from comment #2)
> Is this specific to the vcf format?
No idea, my online testing accounts lack big contact lists.

> Is this a regression?
Yes. Import still works as expected on same device with Boot2Gecko 1.2.0.0-prerelease 20140203225749.
Flags: needinfo?(archaeopteryx)
QA Contact: mvaughan
Attached file LogCat of the issue
This issue appears to only be with VCF files from the SD card (tested importing at least 60 contacts each from Facebook, Gmail, and Outlook & about 35 from the SIM). Furthermore, it looks like there has to be 11 contacts or more on the SD card for this issue to reproduce. Sometimes importing halts at one less than the total number of contacts to import, sometimes it can be four less... it seems to vary depending on how many contacts you want to import. 

I have attached a VCF file with 11 contacts & a LogCat of the issue.
This issue started reproducing on the 11/13/13 1.3 build.

- Works -
Device: Buri v1.3 MOZ RIL
BuildID: 20131112040207
Gaia: a013d01d3a0ddee76f60e61f8306d280c10aafbf
Gecko: 581d180a37f3
Version: 28.0a1
Firmware Version: V1.2-device.cfg

- Broken -
Device: Buri v1.3 MOZ RIL
BuildID: 20131113040200
Gaia: 7243b75041c93bc7deb240131748d0b164f3f0b0
Gecko: 7b014f0f3b03
Version: 28.0a1
Firmware Version: V1.2-device.cfg
triage: 1.3+ regression
blocking-b2g: 1.3? → 1.3+
Assignee: nobody → gtorodelvalle
Attached file 15982.html
Asking review from Francisco since he is familiar with the involved code ;-) Thanks!
Attachment #8370792 - Flags: review?(francisco.jordano)
Comment on attachment 8370792 [details]
15982.html

Tried and working perfectly, thanks German, please merge once travis is green (just relaunched the job)
Attachment #8370792 - Flags: review?(francisco.jordano) → review+
Target Milestone: --- → 1.4 S1 (14feb)
Merged in master: https://github.com/mozilla-b2g/gaia/commit/9e7058e2a521ebfd8cd84507663213aaf2063159
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 9e7058e2a521ebfd8cd84507663213aaf2063159
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(gtorodelvalle)
This issue occurs on the buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20140210004002
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/9c9382f433c0
Gaia: 5c8416fb1ea4a27f172ee6386ab3c19135448506
Platform Version: 28.0
Firmware Version: v1.2-device.cfg

The user will be stuck on the "Importing contacts from memory card" screen when trying to import contacts.
Whiteboard: burirun1.3-3
Attached file 16121.html
Yeah, yeah, it has not been uplifted to v1.3 yet since we found many conflicts due to solving JSHint errors in the patch prepared for master. Anyhow, I created a new PR including the changes needed to solve the issue in v1.3 as well as solving these conflicts. For additional security in the uplifting, I created a PR and Francisco will kindly review it ;-) Thanks!

We'll need-info you, ktucker, once this lands in v1.3 so you are able to verify it again. Thanks!
Attachment #8373921 - Flags: review?(francisco.jordano)
Flags: needinfo?(gtorodelvalle)
Comment on attachment 8373921 [details]
16121.html

Looking good in 1.3, thanks German!
Attachment #8373921 - Flags: review?(francisco.jordano) → review+
ktucker, this bug is ready for verification in v1.3 ;-) Thanks!
Flags: needinfo?(ktucker)
This issue no longer reproduces on the Buri v 1.3.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20140218004003
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/b5afe0b10e93
Gaia: df60e9b49207d64da5647ab15760c122adabfba4
Platform Version: 28.0
Firmware Version: v1.2-device.cfg

The user can import contacts from a memory card without it hanging on the import screen.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Duplicate of this bug: 977483
You need to log in before you can comment on or make changes to this bug.