Unable to use Eclipse with Fennec

RESOLVED DUPLICATE of bug 853045

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 853045
4 years ago
a year ago

People

(Reporter: vijay krishna m, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20131206145143

Steps to reproduce:

I checked out Mozilla Fennec code and I am able to build and install it in my Samsung Galaxy Mega. I tried to connect it to Eclipse using instructions in link: https://wiki.mozilla.org/Mobile/Fennec/Android#Connecting_Eclipse_to_Android_Build_tree




Actual results:

It is not creating projects correctly.

Here is output from create_projects.pl script:

vijay@vijay-Inspiron-5520:~/mozilla_sources/eclipse-mobile/eclipse_mobile$
./create_projects.pl 
OBJ:/home/vijay/mozilla_sources/src/objdir-droid
SRC:/home/vijay/mozilla_sources/src
APPNAME:fennec
APPDIR:mobile/android
sh: 2: /home/vijay/mozilla_sources/src/objdir-droid/mobile/android/base/AndroidManifest.xml: Permission denied
sh: 3: /home/vijay/mozilla_sources/src/objdir-droid/mobile/android/geckoview_library /AndroidManifest.xml: Permission denied
Adding Manifest from: /home/vijay/mozilla_sources/src/objdir-droid/mobile/android/tests/background/junit3/AndroidManifest.xml
/home/vijay/mozilla_sources/src/objdir-droid/mobile/android/base/AndroidManifest.xml
/home/vijay/mozilla_sources/src/objdir-droid/mobile/android/geckoview_library/AndroidManifest.xml
No such file or directory at ./create_projects.pl line 52.


Here are contents of my mozconfig_values file:


MOZOBJDIR=/home/vijay/mozilla_sources/src/objdir-droid
MOZSRCDIR=/home/vijay/mozilla_sources/src

When i try to run project I get an error message in eclipse:

Your project contains error(s), Please fix them before running application.



Expected results:

I should be able to run project according to wiki link.
(Reporter)

Comment 1

4 years ago
I also asked same question in stackoverflow: http://stackoverflow.com/questions/21266972/unable-to-use-fennec-with-eclipse
(Reporter)

Updated

4 years ago
OS: Windows 7 → Linux

Updated

4 years ago
Flags: needinfo?(nalexander)
Hi vijay, the Perl scripts you are running are rather old and are not maintained or supported.  I did a bunch of work on making this better, but had to put it aside before I got it landed into the tree.  You can see my work in progress patch at Bug 853045 [1].  I haven't tried these patches recently, but I have a few hours today and will try to make sure they work and update them if they don't.  Bug reports appreciated!

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=853045
Flags: needinfo?(nalexander)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853045
You need to log in before you can comment on or make changes to this bug.