Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: bll, Assigned: saari)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.3) Gecko/20010808
BuildID:    2001080817

Solaris 8 - Mozilla 0.9.3 Xlib

Cut/Paste are not active, and do not work.

Reproducible: Always
Steps to Reproduce:
A. 1. Select text from another window.
    2. Edit->Paste not active.
    3. Ctrl-V not active.
B.  1. Select text displayed in mozilla.
     2. Edit->Copy not active.
C. 1. Select text in form field in mozilla.
    2. Move cursor to menubar in mozilla.
    3. Text is deselected.

Actual Results:  Unable to cut/paste using any method.

Expected Results:  Be able to cut/paste text.
(Reporter)

Comment 1

17 years ago
Discovered that selecting text from another window
and using the middle button to paste to a field is working.
Ctrl-V is working.
I initially had problems trying to paste to a password field.  Can't reproduce now.

Menu items are not active. 

The Paste button in Solaris is not pasting the cut buffer,
but the selected text in the window.
Normally, I can select some text, press the cut key, select some other text.
The selected text can be pasted w/the middle button.  The text grabbed w/the cut
key can be pasted w/the paste key.


Whiteboard: adsfasdf
->editor
Assignee: pchen → brade
Component: XP Apps → Editor
QA Contact: sairuh → sujay

Comment 3

17 years ago
Is this a duplicate bug?  Is this a focus bug?  Is it Solaris specific?
Akkana--can you reproduce?
Whiteboard: adsfasdf

Comment 4

17 years ago
I see it off and on: it's inconsistent, and always has been.  Just now when I
tested it, I selected text in another window, moused into mozilla and Paste
wasn't active; but when I selected text within this browser window, the menus do
the right thing (copy becomes active, and cut also does if it's a text control).
We've had lots of bugs covering problems with these menus in the composer
window.  I don't have any bug numbers offhand, though I know Simon has been
involved with some of them in the past.

It might have something to do with the primary vs. clipboard selection disparity
in Unix.  Not sure who owns X clipboard these days; Pavlov or blizzard might know.
(Reporter)

Comment 5

17 years ago
Ok.  I can reproduce item (A) above.

1. Start mozilla
2. Go to any web page w/a form.
3. Select text in another window
   [ CDE; Focus follows mouse ].
4. Select form field, middle button to paste
   --> does not work.
5.    Type text in form field;
      Select text in form field.
   or Select any text in mozilla window.
6. Now select text in other window.
7. Select form field, middle button to paste
    --> now works.  Ctrl-V is not working.

Similarly to get Ctrl-V to work, select some text in the
mozilla window, Ctrl-C to copy; Ctrl-V is now working.

(B) Menu cut/paste/copy items not active is consistent.
    Copy seems to become active occasionally, though it doesn't work.
(C) Form field text deselected when moving cursor to menu is
    consistent.  Interesting.  I can select text in the mozilla
    window, move the cursor to the form field, and select additional
    text.  Moving the cursor to the menu at that point, and the 
    ordinary text goes from blue to gray, the form field text is
    deselected.

Comment 6

17 years ago
I still own the clipboard I suppose.... Nothing has changed in the clipboard 
code in a *really* long time... I expect any issues related to it are related to 
the auto-copy-on-select code or other selection/focus changes...

Comment 7

17 years ago
-->selection/focus
Assignee: brade → saari
Component: Editor → Selection

Comment 8

17 years ago
I found this bug while researching nearly identical behavior in Linux.

Intermittently unable to paste from other applications into browser location
field.  Middle mouse button will not paste and Edit->Paste is inactive.

Mozilla build 2001091712
Redhat 7.1
XFree86 4.0.3
twm

Didn't know whether to open a new bug or ask for this one to be recategorized.

Comment 9

17 years ago
Re-reading Stuart's comment that nothing has changed recently prompts me to add
that I've experienced this behavior under Linux in all major releases since 0.9

Comment 10

17 years ago
All three cases (A, B, and C above) work for me with Solaris 7 and build
2001093022. I've seen the problems mentioned previously, but it seems to be
working at the moment.  On case C-3, the text is no longer visually selected,
but both control-V and middle mouse button pasing still work as expected.
(Reporter)

Comment 11

17 years ago
Trying out Solaris 8 - 0.9.4 - Build 20001091520.
Note this is a GTK+/glib version,
 **NOT** the Xlib version that I opened the bug on.

All cut/paste excepting Sun/Solaris cut/paste keys
appear to work just fine in this version.

Comment 12

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Despite Ksosez's mixup, this one really IS WFM. Verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.