Closed Bug 966936 Opened 7 years ago Closed 5 years ago

Glass fog overlaps caption buttons in safe mode

Categories

(Core :: Widget: Win32, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1173617

People

(Reporter: guijoselito, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P4+])

Attachments

(2 files)

Attached image bug ff safe mode.png
When restarting Firefox in Safe Mode I see a problem on the 'minimize/maximize/close' button.
I'm on Windows 7. Not happening on Firefox Beta. Maybe regressed by Australis?
Confirmed here, same problem, Windows 7 x64, Nightly x86, problem persist since Australis landed, with default Aero and  third party Themes.
Possibly related to bug 940455? Tentatively marking as P2, since bug 940455 is P2.
See Also: → 940455
Whiteboard: [Australis:P2]
Safe-mode only minor glitch, I think not P2.
Whiteboard: [Australis:P2] → [Australis:P3-]
This is a widget bug; some debugging shows that nsUXThemeData ends up with the buttons' heights at 13 instead of 17, which is causing the cleared region for the buttons to be the wrong size, which leads to the fog overlapping. Don't know why it's wrong in safe-mode and not in normal mode, because I can't seem to get MSVS to debug from Firefox's start (instead of attaching later) and so nsUXThemeData has already been initialized.
Component: Theme → Widget: Win32
Product: Firefox → Core
(In reply to :Gijs Kruitbosch from comment #4)
> This is a widget bug; some debugging shows that nsUXThemeData ends up with
> the buttons' heights at 13 instead of 17, which is causing the cleared
> region for the buttons to be the wrong size, which leads to the fog
> overlapping. Don't know why it's wrong in safe-mode and not in normal mode,
> because I can't seem to get MSVS to debug from Firefox's start (instead of
> attaching later) and so nsUXThemeData has already been initialized.

Jim, do you have time to investigate this and/or do you know someone who can?
Flags: needinfo?(jmathies)
DwmGetWindowAttribute is returning smaller dims for the titlebar button box when we're in safe mode. Not sure why. I'll try to find some time to poke at it.

normal: 102 x 28
safe mode: 102 x 15
Flags: needinfo?(jmathies)
Summary: Visual error in safe mode → Glass fog overlaps caption buttons in safe mode
Whiteboard: [Australis:P3-] → [Australis:P4+]
Since Nightly 2014-05-21 they are now completely covered in fog.

I assume it's because of OMTC being enabled by default (bug 899785).
(In reply to Elbart from comment #7)
> Since Nightly 2014-05-21 they are now completely covered in fog.
> 
> I assume it's because of OMTC being enabled by default (bug 899785).

Is this in or outside safemode, or both? If it's outside safe mode, please file a new bug.
Flags: needinfo?(elbart)
(In reply to :Gijs Kruitbosch from comment #8)
> (In reply to Elbart from comment #7)
> > Since Nightly 2014-05-21 they are now completely covered in fog.
> > 
> > I assume it's because of OMTC being enabled by default (bug 899785).
> 
> Is this in or outside safemode, or both? If it's outside safe mode, please
> file a new bug.

(note also bug 980642, but that was fixed, so if this is still happening outside of safe mode, we need to figure out why that is in a new bug that depends on bug 980642)
Attached image safe mode with OMTC on
I'm pretty sure he's talking about safe mode, cause that's what I'm seeing.
The fog used to be at the bottom part of the buttons, and now it's on the entire button.
(In reply to :Gijs Kruitbosch from comment #8)
> Is this in or outside safemode, or both? If it's outside safe mode, please
> file a new bug.

The bug is about safe mode, isn't it? So yes, it's fully covered in safe mode.
Flags: needinfo?(elbart)
After any of these three bugs landed
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9c4c4356afce&tochange=fc8ba992b5b0

the fog is now back to only overlapping the buttons, not fully covering them.
Depends on: 1059804
Duplicate of this bug: 1070879
Depends on: 1108217
This seems to have been fixed by bug 1173617 for Firefox 41 and later.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1173617
You need to log in before you can comment on or make changes to this bug.