Closed Bug 966956 Opened 6 years ago Closed 6 years ago

Clicking API-created buttons in the toolbar is broken

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(1 file)

Sigh.

bug 966684 comment 8

Clearly, I can't get this right.

This is because for API-created widgets, we always call maybeAutoHidePanel in handleWidgetClick. Even if they're in the toolbar. Arguably, we shouldn't, but here we are.
As far as I can tell, just removing the calls is fine, but I've gone ahead and also added a guard to ensure that that function doesn't error if you call it on something that doesn't have a panel above it.
Attachment #8369379 - Flags: review?(bmcbride)
Attachment #8369379 - Flags: review?(bmcbride) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/97a219047ea9
Status: NEW → ASSIGNED
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
Duplicate of this bug: 967004
https://hg.mozilla.org/mozilla-central/rev/97a219047ea9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 29
QA Contact: cornel.ionce
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

Verified fixed on Firefox 29 beta 6 (build ID: 20140407135746).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.