Adding visual cues to errors in the code that scroll with the user's view in Remix

RESOLVED DUPLICATE of bug 967552

Status

Webmaker
Thimble
--
enhancement
RESOLVED DUPLICATE of bug 967552
4 years ago
4 years ago

People

(Reporter: omnignorant, Assigned: pomax)

Tracking

Details

(Reporter)

Description

4 years ago
Right now, when there is an error in the code other Thimble features are not available (for instance, clicking into tags to get help). If you are not a seasoned user, you wouldn't even know to look for errors as you try to remix the code. Even if you are seasoned, you are forced to scroll around away from where you are working to find it and it is not always visually striking.

I would suggest some kind of alert that appears static at the top of the page, or scrolls with the window view, to help users navigate to the error.
(Reporter)

Comment 1

4 years ago
NOTE that I kinda added a redundant bug: 967552
(Assignee)

Updated

4 years ago
Assignee: nobody → pomax
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967552
You need to log in before you can comment on or make changes to this bug.