Closed Bug 967146 Opened 6 years ago Closed 6 years ago

talos xperf regression: Main Startup File IO Bytes, regressed Jan 21st and Feb 1st

Categories

(Core :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 970123
mozilla30

People

(Reporter: jmaher, Assigned: ehsan)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

Taking a look a the graphs on graph server, I see some interesting changes in the xperf data:
http://graphs.mozilla.org/graph.html#tests=[[242,63,25]]&sel=none&displayrange=30&datatype=running

In general this data is pretty stable, so a change is noticed.
I strongly suspect the large increase on the 21st is this patch:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ecb4c7413d5
the second jump appears to be when we switched tofrom icu*50.dll to icu*52.dll:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2efbd5388bc7
aklotz, can you confirm this is expected so we can resolve this bug as wontfix?
This is expected in the sense that we know where it came from and why. OTOH, I think that we might want to talk to some people about this functionality and find out whether we can defer its initialization or something.
Flags: needinfo?(ehsan)
Component: Talos → General
Product: Testing → Core
Vladan, I'm not sure what kind of information you're asking from me.  Please be more specific!  :-)
Flags: needinfo?(ehsan)
Depends on: 970123
With bug 970123 fixed, can you please verify that the regression has gone away?  Thanks!
Flags: needinfo?(jmaher)
thanks for fixing bug 970123, this has resorted back to almost the original level.  There was another slight bump while this bug was open, so 2 regressions and we are back down to about 1/2 of the second bump.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jmaher)
Resolution: --- → FIXED
Assignee: nobody → ehsan
Target Milestone: --- → mozilla30
Resolution: FIXED → DUPLICATE
Duplicate of bug: 970123
FWIW:



Improvement: Mozilla-Inbound - Tp5 No Network Row Major MozAfterPaint (Main Startup File IO Bytes) - WINNT 6.1 (ix) - 20.6% decrease
------------------------------------------------------------------------------------------------------------------------------------
    Previous: avg 51691558.333 stddev 7263.790 of 12 runs up to revision dfa1bf6d4c60
    New     : avg 41023258.333 stddev 222637.877 of 12 runs since revision 0050e64d10c8
    Change  : -10668300.000 (20.6% / z=1468.696)
    Graph   : http://mzl.la/1c2sL2Q

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dfa1bf6d4c60&tochange=0050e64d10c8

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/772392d933ea
    : L. David Baron <dbaron@dbaron.org> - Bug 434102 followup:  Mark reftest as failing on Mac.
    : http://bugzilla.mozilla.org/show_bug.cgi?id=434102

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/94e20568f4e8
    : L. David Baron <dbaron@dbaron.org> - Update test failure annotation for bug 791480, now that we're running tests on Windows NT 6.2 as well.
    : http://bugzilla.mozilla.org/show_bug.cgi?id=791480

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/8a514146f4f3
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973389 - Move the LOCAL_INCLUDES in mozglue to moz.build; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973389

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/e72376b70bed
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973391 - Move the LOCAL_INCLUDES in webapprt to moz.build; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973391

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/1a4c5d3a814c
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973403 - Move the LOCAL_INCLUDES in memory to moz.build; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973403

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/658a158fa868
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973402 - Move the LOCAL_INCLUDES in js/src to moz.build; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973402

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/dd6e74de8855
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973646 - Port some CXXFLAGS logic in js/src/Makefile.in to the DEFINES variable; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973646

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/4bc79e20fae0
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 973395 - Move the LOCAL_INCLUDES in media to moz.build; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=973395

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/0050e64d10c8
    : Ehsan Akhgari <ehsan@mozilla.com> - Bug 970123 - Avoid read-aheading icudt52.dll for better startup performance; r=glandium
    : http://bugzilla.mozilla.org/show_bug.cgi?id=970123
You need to log in before you can comment on or make changes to this bug.