Closed Bug 967159 Opened 6 years ago Closed 6 years ago

[B2G][Settings][FDN] There is no indication to alert the user when enabling FDN and dialing to a contact that is not on FDN

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 962447

People

(Reporter: selkabule, Unassigned)

Details

(Keywords: l12y, Whiteboard: LocRun1.3)

Description:
when enabling FDN and attempting to call a contact that is not on the FDN white list, The user is not notified that the number is not on the whit list 

Repro Steps:
1) Updated Buri to Build ID: 20140203004001
2) Enable FDN from settings app
3) Launch the Contact app and select a contact not on the FDN white list
4) Tap on the phone number

Actual Result: 
No response

Expected:
A page shows that the number I am dialing is not on the white list

Notes: 
This is a hard coded issue the occurs on all localized languages 

Environmental Variables
Device: Buri V1.3 MOZ RIL
Build ID: 20140203004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/3d9d920ca43b
Gaia: f9a37c77efb4621a1f57e4695b497d18601fe134
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg


Repro frequency: 100%
See attached: Video clip (http://www.youtube.com/watch?v=ZaHA5WHOjRM&edit=vd)
What happens on 1.1?
Keywords: qawanted
There is no FDN feature on 1.1
Keywords: qawanted
Okay - what about 1.2?
Keywords: qawanted
FDN wasn't an enabled feature until 1.3
Keywords: qawanted
(In reply to Sarah Parsons from comment #4)
> FDN wasn't an enabled feature until 1.3

No. FDN was enabled in 1.2.
Keywords: qawanted
Unable to test in latest 1.2 build due to bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=972103
Blocks: 972103
Fugu has same problem.

Fugu
Gaia      26e8a950f3ac703310ee8efcb741ff2418e9d190
Gecko     0d2a915d0b66dba35ee9936bdeafef820a5c3357
BuildID   20140217152248
Version   28.0
No longer blocks: 972103
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 962447
You need to log in before you can comment on or make changes to this bug.