N621 M099 Trunk bookmark crash [@ MenusLib ]

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P1
critical
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: greer, Assigned: Steve Dagley)

Tracking

({crash, qawanted, topcrash-})

Trunk
mozilla1.0.1
PowerPC
Mac System 9.x
crash, qawanted, topcrash-

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: need more data, crash signature)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This anemic stack is all we have to go on at the moment. I'll log this one in 
case anyone has seen something like this before and I will try to get in touch 
with some of the users who have managed to crash. Pls. reassign to the right 
component.

Stack Trace: 

         MenusLib + 0x9e4 (0x3f96fe74)
         MenusLib + 0x84b0 (0x3f977940)
         MenusLib + 0x8444 (0x3f9778d4)
         MenusLib + 0x7e54 (0x3f9772e4)
         MenusLib + 0x772c (0x3f976bbc)
         MenusLib + 0x7a70 (0x3f976f00)
         MenusLib + 0x7280 (0x3f976710)
         MixedMode + 0x11bc (0xffcec2dc)
         0x010123fc     
     (34406732)      Comments: accessing sidebar history
     (34406584) Comments: filing a bookmark
     (34400649) Comments: trying to go to a site via the bookmarks. 
     (34377063) Comments: printing from Quark Xpress
     (34346093) Comments: trying to move to another URL
     (34313314) Comments: Just accessing the bookmark file. Happenend twice now 
always a crash with a type 2 error.
     (34298964) Comments: starting up
     (34289393) Comments: going into my bookmarks
     (34288167) Comments: Opening web site from my bookmark file.
     (34278921) Comments: Not aware of a crash.   Installing 6.1 when this came
on.

The crash is happening primarily on v.9.1:
   2 MacOS version 8.6
   3 MacOS version 9.0.4
  18 MacOS version 9.1
   3 MacOS version 9.2.1
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 1

17 years ago
nav triage team:

reassigning to pchen for investigation, marking nsbeta1+, p1, and mozilla0.9.4
Assignee: ben → pchen
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.4

Updated

17 years ago
Keywords: qawanted

Comment 2

16 years ago
This bug doesn't have enough data for me to even begin to fix. Pushing out to
mozilla0.9.5
Whiteboard: need more data
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 3

16 years ago
Haven't gotten any more data, moving on to mozilla0.9.6
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 4

16 years ago
Still no more data, pushing out to mozilla0.9.7
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Reporter)

Comment 5

16 years ago
This signature isn't showing up in Trunk or N620. M095 has a single Talkback
entry with no comment. Marking WFM. I will reopen if we get more (meaningful) data.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
Reopening as a topcrash on N620 Mac for the stack signature: MenusLib

There are 35 crashes in todays topcrash report for this stack sig.

Min/Max Seconds since last crash: 14 - 190932
Min/Max Runtime: 14 - 463277
Crash data range: 2001-10-30 to 2001-11-08
Build ID range: 2001102217 to 2001102217
Keyword List : bookmark(9), netscape(4), 
Stack Trace: 

	 MenusLib + 0xba8 (0x2f436828)
	 MenusLib + 0x2280 (0x2f437f00)
	 MixedMode + 0x115c (0x004f141c)
	 0x001e62c5

COMMENTS/URLs:
	 
     (37770101)	Comments: i was trying to play a game at Yahoo games.  This damn drowser
keeps telling me a need a plugin  and then it says there are no plugins for what
i need.   I had absolutely no problems playing the games in the earlier Netscape
versions  and now I can't play
     (37770101)	Comments:  the Excite or Yahoo games.  If there is no plugin  then what is
the problem?  This sucks.  
     (37741297)	Comments: I was scrolling down my bookmarks list
     (37722481)	Comments: you have not fixed the problem--the computer freezes when you try
to print!!!
     (37706045)	URL:
http://quote.yahoo.com/q?s=^DJI+^IXIC+AAPL+BPT+CSCO+EMC+JDSU+LUV+MGG+NOK+PBT+SBR+SUNW+VRTS+WMT+FDGFX+FBGRX+FGRIX+FBIOX+FShttp://quote.yahoo.com/q?s=^DJI+^IXIC+AAPL+BPT+CSCO+EMC+JDSU+LUV+MGG+NOK+PBT+SBR+SUNW+VRTS+WMT+FDGFX+FBGRX+FGRIX+FBIOX+FSPTX&d=v1
     (37706045)	Comments: This error is reproducible.I start Netscape (to an initial blank
screen).  I select the above URL from my Bookmarks (via the top menu line). 
Next I select a new  Netscape screen (cmd N) via the File menu and then go to
click Bookmarks.  The drop down
     (37706045)	Comments:  menu of Bookmarks at first does not appear.  I re-click the mouse
button and the drop down menu appears.  I then close the blank window (clicking
the close box in the upper left corner).  Then I again create a new  blank
Netscape window via cmd N under
     (37706045)	Comments:  File menu item.  I again click Bookmarks and the drop down list
appears at the far right upper right of my screen (not under the Bookmark menu
item).  I re-click the mouse button and the drop down menu appears where it
should.  Close this blank window
     (37706045)	Comments:  via the close box and for the third time create a blank Netscape
window.  When I then selet the Bookmark menu item Netscape quits with a Type 2
error.
     (37704006)	Comments: Opening bookmarks meny
     (37670819)	Comments: trying to open a bookmarked URL
     (37664295)	Comments: clicked on link to target@amazon.com from www.dealmac.com
     (37640402)	Comments: Trying to get my old 6.2 data to the new formatted disk.
     (37632993)	Comments: Same as all the other times...selected Bookmarks and got immediate
crash
     (37621162)	Comments: just opened www.google.com
     (37617680)	Comments: Had selected Bookmarks on the menu line; instant crash before
pulldown menu even displayed
     (37607069)	Comments: Opening Bookmarks after importing an old file from Netscape 4.76
     (37573976)	Comments: starting it up
     (37557723)	Comments: I had displayed my Yahoo stock portfolio page with no problems.  I
then went and clicked on the Bookmarks item on the main/top menu line and
Netscape immediately crashed.
     (37507811)	Comments: Nothing: I'd gone home
     (37467529)	URL: ww.nytimes.com
     (37467529)	Comments: selecting a bookmark imported from IE 5
     (37458720)	Comments: nothing.  this program is not working.



Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: N610 bookmark crash [@ MenusLib ] → N620 bookmark crash [@ MenusLib ]

Comment 7

16 years ago
Moving to mozilla0.9.9 because none of this data helps me at all.

Claudius, can you spend some time to try and reproduce this one?
Target Milestone: mozilla0.9.7 → mozilla0.9.9

Comment 8

16 years ago
my talkback query skills evidently aren't as good as my bugzilla query skills.
I'm getting nothing for this stack sig. Jan or Jay, can someone tell me what
recent build ID's have shown crashes with this same sig? (before I go off trying
to repro?)
(Reporter)

Comment 9

16 years ago
Claudius, The latest crshes with this signature happen on the M096 release 
(Incidents 38394310, 38393485). We don't have any Trunk crashes for this one at 
the moment but since we only have 16 mac incidents on the Trunk in today's data 
that isn't surprising.

Comment 10

16 years ago
Moving out to mozilla1.0.1
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Comment 11

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Status: REOPENED → NEW

Comment 12

16 years ago
Claudius, does this still deserve topcrash status?

Comment 13

16 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Updated

16 years ago
Assignee: ben → sdagley

Comment 14

16 years ago
--> dagley

Pls verify this is still a Top Crash, or crash at all?
(Reporter)

Comment 15

16 years ago
Created attachment 71343 [details]
User comments

The past ten days of data return 215 incidents on N621, 13 on M098 and 1 on the
Trunk. It needs a fix but we still need a solid repro case.
Attaching user comments.

Comment 16

16 years ago
Could this be related to the Yahoo Games crasher, which occurs when Java games
are accessed? If so, Sun and Yahoo are working on that. 

Comment 17

16 years ago
I've been having Mac problems all week so I just got to this but I'm unable to
generate a crash. That of course doesn't mean much as we do have data that says
it's a problem. I'm just saying that no combination of QA artistry and wizardry
has enabled me to repro this bug (2002022808 Mac Classic builds).

Comment 18

16 years ago
nsbeta1+ per ADT/Embed triage.
Keywords: nsbeta1 → nsbeta1+

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla1.0

Comment 19

16 years ago
Updating summary with N621 and M098 per Tom's comment #15.  Adding Trunk since
this crash is also still around on the MozillaTrunk.  Here are a couple of
recent incidents:

 Incident ID 3663568   
Stack Signature  MenusLib + 0xc2c (0x008bfa6c) 3e41386c
Trigger Time 2002-03-05 09:52:53
Email Address xslf@yahoo.com
URL visited
Build ID 2002030108
Product ID MozillaTrunk
Platform
Operating System MacOS
Module
Trigger Reason PowerPC unmapped memory exception
User Comments opened the bookmarks menu....
Stack Trace
MenusLib + 0xc2c (0x008bfa6c)
MenusLib + 0x231c (0x008c115c)
MixedMode + 0x11bc (0xffcec3fc)
0x000e0c0d 

 Incident ID 3605910   
Stack Signature  MenusLib + 0x9e0 (0x3f96f200) 3d7c77db
Trigger Time 2002-03-03 21:51:58
Email Address
URL visited
Build ID 2002022508
Product ID MozillaTrunk
Platform
Operating System MacOS
Module
Trigger Reason PowerPC unmapped memory exception
User Comments I was trying to select an entry in bookmark pull down menu.There
were more than 10 windows open.
Stack Trace
MenusLib + 0x9e0 (0x3f96f200)
MenusLib + 0x84c0 (0x3f976ce0)
MenusLib + 0x8454 (0x3f976c74)
MenusLib + 0x85d4 (0x3f976df4)
MenusLib + 0x7788 (0x3f975fa8)
MenusLib + 0x7a80 (0x3f9762a0)
MenusLib + 0x7290 (0x3f975ab0)
MixedMode + 0x11bc (0xffcec3fc)
0x00010afc 

The stacks still aren't very helpful, but at least we know we're still crashing.
   Still need a solid testcase though.
Summary: N620 bookmark crash [@ MenusLib ] → N621, M098, Trunk bookmark crash [@ MenusLib ]

Updated

16 years ago
Keywords: nsbeta1+ → nsbeta1-

Comment 20

16 years ago
minus until we have a testcase

Comment 21

16 years ago
Adding M099 to summary since I see incidents showing up already for Mozilla
0.9.9...but I'm also going to mark this topcrash- since there just aren't a lot
of these crashes (about 1.5% of all Mac crashes are of this type)...and no one
has been able to reproduce.

Claudius: We'll post more info as we get it from Talkback...when we do, you
might want to try to reproduce this again.  If you can't this might be worth a
worksforme.
Keywords: topcrash → topcrash-
Summary: N621, M098, Trunk bookmark crash [@ MenusLib ] → N621 M099 Trunk bookmark crash [@ MenusLib ]

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 22

16 years ago
I don't understand.  How can this be topcrash if you say "...but I'm also going
to mark this topcrash- since there just aren't a lot of these crashes (about
1.5% of all Mac crashes are of this type"?

Thanks

Comment 23

16 years ago
Lisa:  The reason we came up with the topcrash+ and topcrash- system is to
ensure that we never have to remove the topcrash keyword from the summary. 
Although this might not be a "topcrash" anymore...we still need to keep track of
it because this  *was* at some point a major problem and therefore has the
potential be a problem again (unless of course we get it fixed or mark it
worksforme).  For now...this is not a crash we feel is critical (or else it
would be marked topcrash+).  

Comment 24

16 years ago
I'm going to close this bug out as worksforme.  There are too many differenct
kinds of crashes being reported under this stack signature and we have not been
able to find a single testcase to reproduce this at will.  This might just be a
generic stack signature for all types of crashes with MacOS...so I don't see
this bug going anywhere.

If anyone does see this stack signature in Talkback data, please try to
reproduce it first and then log a new bug for your particular task or testcase
that is causing a crash.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
Crash Signature: [@ MenusLib ]
You need to log in before you can comment on or make changes to this bug.