Closed Bug 967321 Opened 6 years ago Closed 6 years ago

Feature Request - Make about:newtab part of history

Categories

(Firefox :: Tabbed Browser, enhancement)

26 Branch
x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 776167

People

(Reporter: akumaxyz, Unassigned)

Details

(Whiteboard: [bugday-20140210])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

* Open Firefox
* Open a New Tab (equivalent of about:newtag)
* Click on any one of your popular home links (9 pages - 3 x 3 grid)
* Click Back


Actual results:

Nothing - when you click on one of your popular home link pages, it instantiates it as the 1st page in your current browsing session for that tab.


Expected results:

It should go back to your New Tab page

Work around:
* when opening a new tab, go to about:newtab in your address bar.  
* it will instantiate it as the 1st page, so when you click on a popular home link, and then press Back in the browser, it will go back to about:newtab
Severity: normal → enhancement
Reproduced with 28.0b1 and 2014-02-10-03-02-01-mozilla-central-firefox-30.0a1.en-US.linux-x86_64.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: Untriaged → Tabbed Browser
OS: Mac OS X → All
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20140210]
Duplicate of bug: 776167
You need to log in before you can comment on or make changes to this bug.