Closed Bug 967370 Opened 6 years ago Closed 6 years ago

Remove duplication in UITour browser chrome tests

Categories

(Firefox :: General, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: MattN, Assigned: MattN)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Bug 956202 by duplicating about 70 lines in every UITour test file.

I used 3-way merges to make sure I didn't miss differences.

 browser/modules/test/browser_UITour.js      |  74 +-----------------------------
 browser/modules/test/browser_UITour2.js     |  68 +----------------------------
 browser/modules/test/browser_UITour3.js     |  68 +----------------------------
 browser/modules/test/browser_UITour_sync.js |  66 +---------------------------
 browser/modules/test/head.js                |  72 ++++++++++++++++++++++++++++++
 5 files changed, 79 insertions(+), 269 deletions(-)
Attachment #8369871 - Flags: review?(bmcbride)
Attachment #8369871 - Flags: review?(bmcbride) → review+
Comment on attachment 8369871 [details] [diff] [review]
v.1 Dedupe two functions

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 956202 
User impact if declined: None, the developer impact is that Aurora and m-c test files will be different making test uplift hard.
Testing completed (on m-c, etc.): m-c now. Test-only change
Risk to taking this patch (and alternatives if risky): Test-only cleanup
String or IDL/UUID changes made by this patch: None
Attachment #8369871 - Flags: approval-mozilla-aurora?
Attachment #8369871 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/cea89064bf58
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.