All users were logged out of Bugzilla on October 13th, 2018

[DSDS] No audio and unable to end the emergency call while dialing 911 soon after reboot device with no SIM card.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: echu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dsdsrun1.3 [POVB])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8369911 [details]
time stamp: 17:-2, 2/4

+++ This bug was initially created as a clone of Bug #959914 +++

After verified on latest Fugu, when there is no SIM and try to dial out emergency call, call will be connected but there is no sound from receiver and the call cannot be ended as well. Nominate as 1.3 blocker.
(Reporter)

Comment 1

5 years ago
Test on 
Fugu
Gaia      bb36b4164d3e51ca04b612e507e1178f80bf240d
Gecko     4227240a4d3e1e418ced160c2a48cb454d7b5645
BuildID   20140204104742
Version   28.0
David

Can you please look at it from Contacts perspective?
Flags: needinfo?(dscravaglieri)
Preeti, could you be more explicite ?
Flags: needinfo?(dscravaglieri) → needinfo?(praghunath)
Not even going to wait for triage on this one - emergency calls have to work. Going to block this.
blocking-b2g: 1.3? → 1.3+
Hi Hsinyi, can you take a look at this bug? thanks
Flags: needinfo?(htsai)
(Reporter)

Comment 6

5 years ago
Hi all,

I cannot reproduce the bug on latest build. Change the bug to works for me first.
Fugu
Gaia      ed8e558f6396cd1644d1ff5d9a405894c9486d76
Gecko     ad4235248f61a4b2b1d6ff7497953bee51d05e32
BuildID   20140206061636
Version   28.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(praghunath)
Flags: needinfo?(htsai)
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

5 years ago
Sorry for reopening the bug again because I found the correct way to reproduce the bug. User has to dial 911 right after reboot and dialer icon shows. Then the bug can be reproduced.

1. No SIM in device, reboot it.
2. Once dialer icon is available, open it and dial 911.
3. No audio can be heard and unable to end the call.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [DSDS] No audio and unable to end the emergency call while dialing 911 with no SIM card in device. → [DSDS] No audio and unable to end the emergency call while dialing 911 soon after reboot device with no SIM card.
(Reporter)

Comment 8

5 years ago
Created attachment 8371227 [details]
time stamp: 12:12, 2/6
(In reply to Enpei from comment #8)
> Created attachment 8371227 [details]
> time stamp: 12:12, 2/6

Log indicates that audio system has been correctly set by RIL. After dialing 911, there are messages: |I/Gecko   (  108): TelephonyProvider: Active call, put audio system into PHONE_STATE_IN_CALL: 2|. Not sure if there's something wrong in audio module. We need audio team's help.

Regarding pending call issue:
RIL indeed receives hangUp request from gaia and sends that to RILD/modem. Then, RIL receives unsolicited call state change event and sends out another get_current_calls request (type 9) to RILD/modem. However, from the log, I don't see the response of type 9 from RILD/modem so that RIL cannot correctly update the call state to DISCONNECTED. I think that's why the call object is pending.
Created attachment 8371265 [details]
RIL log: -b radio -b main

log extract:

02-05 04:40:21.210 I/Gecko   (  105): RIL Worker[0]: Received chrome message {"callIndex":1,"rilMessageToken":14,"rilMessageType":"hangUp"}

02-05 04:40:21.290 I/Gecko   (  105): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED

02-05 04:40:21.290 I/Gecko   (  105): RIL Worker[0]: New outgoing parcel of type 9 <== GET_CURRENT_CALLS

After 1 minute, gecko received the response of REQUEST_HANGUP and REQUEST_GET_CURRENT_CALLS. Both requests failed.

02-05 04:41:11.000 I/Gecko   (  105): RIL Worker[0]: Solicited response for request type 12, token 36, error 2
02-05 04:41:11.000 I/Gecko   (  105): RIL Worker[0]: Handling parcel as REQUEST_HANGUP

02-05 04:41:15.999 I/Gecko   (  105): RIL Worker[0]: Solicited response for request type 9, token 37, error 2
02-05 04:41:15.999 I/Gecko   (  105): RIL Worker[0]: Handling parcel as REQUEST_GET_CURRENT_CALLS

Sam, do you have any idea of the failure here?
Flags: needinfo?(sam.hua)

Updated

5 years ago
Attachment #8371265 - Attachment mime type: text/x-vhdl → text/plain

Comment 11

5 years ago
Sorry,i can't reproduce it in the latest our build.

Any sprd_patches applied to the build? now I don't know whether there are some difference between our build.
Flags: needinfo?(sam.hua)
(Reporter)

Comment 12

5 years ago
(In reply to sam.hua from comment #11)
> Sorry,i can't reproduce it in the latest our build.
> 
> Any sprd_patches applied to the build? now I don't know whether there are
> some difference between our build.

Hi Sam,

To reproduce the bug, one has to dial out 911 as soon as possible after reboot device. Or the bug cannot be reproduce. Have you launched dialer once you saw show up after reboot device and dial emergency call immediately?

Comment 13

5 years ago
Hi enpei,

I reproduce it, if i call 911 immediately after reboot.
(In reply to sam.hua from comment #13)
> Hi enpei,
> 
> I reproduce it, if i call 911 immediately after reboot.

Do you have any idea of comment 10?

Comment 15

5 years ago
Sam , any update? Thanks.
Flags: needinfo?(sam.hua)

Comment 16

5 years ago
It maybe modem's issue.

I find  Channel1: AT< +CLCC: 1,0,0,0,0,"911",129 in the log.txt, but the emergency call shouldn't enter the active state.
and there isn't any correct response from modem after send "AT+CHLD" to modem.
If i don't hangup the call,
D/AT      (  103): [w] Channel0: AT< ^DSCI: 1,0,6,0,0,911,129,,31   //indicate that call is ended.
D/RILC    (  103): [w] [UNSL]< UNSOL_RESPONSE_CALL_STATE_CHANGED 
D/AT      (  103): [w] Channel0: AT< *SPCSC: 1,20,,,,1,67,31
D/AT      (  103): [w] Channel1: AT> AT+CLCC
D/AT      (  103): [w] Channel1: AT< ERROR
the modem maybe crash
Flags: needinfo?(sam.hua)
Enpei - Is the above comment implying that this is a vendor bug on Spreadtrum's side (i.e. not a bug in gecko or gaia)?
Flags: needinfo?(echu)
(In reply to Jason Smith [:jsmith] from comment #17)
> Enpei - Is the above comment implying that this is a vendor bug on
> Spreadtrum's side (i.e. not a bug in gecko or gaia)?

I can answer this -- yes. Log and Sam's comment indicate this seems a vendor bug.
Flags: needinfo?(echu)
Okay - moving to vendcom then. Clearing blocking flag also, as we don't block on vendor issues.
blocking-b2g: 1.3+ → ---
Component: RIL → Vendcom
Whiteboard: [FT:RIL], dsdsrun1.3 → [FT:RIL], dsdsrun1.3 [POVB]

Updated

5 years ago
Whiteboard: [FT:RIL], dsdsrun1.3 [POVB] → dsdsrun1.3 [POVB]

Comment 20

8 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.