"ASSERTION: uninitialized" (nsStandardURL::SetScheme)

RESOLVED DUPLICATE of bug 967341

Status

()

RESOLVED DUPLICATE of bug 967341
5 years ago
2 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8369957 [details]
testcase

###!!! ASSERTION: uninitialized: 'Error', file netwerk/base/src/nsStandardURL.cpp, line 1181

>    frame #3: 0x00000001015a9f55 XUL`NS_DebugBreak(aSeverity=1, aStr=0x00000001071dbcb0, aExpr=0x00000001071b424a, aFile=0x00000001071db78f, aLine=1181) + 1205 at nsDebugImpl.cpp:419
>    frame #4: 0x00000001017c0e37 XUL`nsStandardURL::SetScheme(this=0x00000001259c1e00, input=0x00007fff5fbf6ce0) + 327 at nsStandardURL.cpp:1181
>    frame #5: 0x000000010332c1e2 XUL`mozilla::dom::URL::SetProtocol(this=0x000000012401c580, aProtocol=0x00007fff5fbf6de8) + 274 at URL.cpp:257
>    frame #6: 0x0000000102d806ba XUL`mozilla::dom::URLBinding::set_protocol(cx=0x000000011ef0f340, obj=Handle<JSObject *> at 0x00007fff5fbf6e08, self=0x000000012401c580, args=JSJitSetterCallArgs at 0x00007fff5fbf6df8) + 186 at URLBinding.cpp:428
>    frame #7: 0x0000000102d7f3d7 XUL`mozilla::dom::URLBinding::genericSetter(cx=0x000000011ef0f340, argc=1, vp=0x00007fff5fbf7560) + 679 at URLBinding.cpp:1038
>    frame #8: 0x00000001060df935 XUL`js::CallJSNative(cx=0x000000011ef0f340, native=0x0000000102d7f130, args=0x00007fff5fbf7430)(JSContext*, unsigned int, JS::Value*), JS::CallArgs const&) + 165 at jscntxtinlines.h:220

Security-sensitive because the testcase is similar to the one in bug 967341.
I can confirm this is a dup
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967341
(Reporter)

Updated

5 years ago
Blocks: 1020040

Updated

3 years ago
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.