Closed Bug 967421 Opened 6 years ago Closed 5 years ago

[User Story] Show icon in Task Manager

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1061324
tracking-b2g backlog

People

(Reporter: pdol, Unassigned)

References

Details

(Whiteboard: [ucid:System160, 1.4:P2, ft:systems-fe][systemsfe])

User Story

As a user I want to be able to see the icon associated with the content displayed in Task Manager to make it easier to identify the apps.

Acceptance Criteria:
1. When viewing task manager, I can see the icon associated with the displayed content.
No description provided.
User Story: (updated)
Flags: in-moztrap?(jsmith)
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(jsmith)
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
Whiteboard: [ucid:System160, 1.4:P2, ft:systems-fe] → [ucid:System160, 1.4:P2, ft:systems-fe][systemsfe]
Target Milestone: --- → 2.1 S3 (29aug)
Blocks: 967420
No longer blocks: rocketbar-search-mvp
Just assign an owner on user story bug. Candice, feel free to dispatch the bug to engineering managers or leads if it's much better for then to own the user story bugs. Thank you.
Assignee: nobody → cserran
Assignee: cserran → sfoster
Blocks: 1033971
feature-b2g: 2.1 → 2.2?
Target Milestone: 2.1 S3 (29aug) → ---
Unassigning myself, I'm not currently working on this. 
Leaving this open because: We have icons visible in cards view now, but there is still the open question of browser window icons. Particularly in the case where a user has launched a window from an icon on their homescreen, it seems poor UX to show the generic browser icon for this window in cards view. 

There are 2 part to completing implementation here: 
1. Reuse the AppWindow's icon and/or share code to show the associated icon. Right now the CardsHelper just looks through the manifest.icons and falls back to a hard-coded default in CSS
2. Present icons nicely - we'll need to deal with semi-transparent icons which right now look bad as they overlap the edge of the screenshot. And maintain the slight drop-shadow which is currently implemented via an svg filter
Assignee: sfoster → nobody
This was landed recently with bug 1061324.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061324
feature-b2g: 2.2? → ---
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.