Closed Bug 967432 Opened 6 years ago Closed 6 years ago

Permanent Orange: TEST-UNEXPECTED-FAIL | test-message-header.js | test-message-header.js::test_a11y_attrs

Categories

(Thunderbird :: General, defect)

x86_64
All
defect
Not set

Tracking

(thunderbird29 fixed, thunderbird30 fixed)

RESOLVED FIXED
Thunderbird 30.0
Tracking Status
thunderbird29 --- fixed
thunderbird30 --- fixed

People

(Reporter: standard8, Assigned: enndeakin)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\message-header\test-message-header.js | test-message-header.js::test_a11y_attrs
  EXCEPTION: headerAccessible.name for Subject was 'null'; expected 'Subjec: This is a really, really, really, really, really, really, really, really, long subject.'
    at: test-message-header.js line 997
       verify_header_a11y test-message-header.js 997
       test_a11y_attrs test-message-header.js 1022
       Runner.prototype.wrapper frame.js 585
       Runner.prototype._runTestModule frame.js 655
       Runner.prototype.runTestModule frame.js 701
       Runner.prototype.runTestDirectory frame.js 525
       runTestDirectory frame.js 707
       Bridge.prototype._execFunction server.js 179
       Bridge.prototype.execFunction server.js 183

This is on Windows & Linux (Mac has accessibility disabled due to the same failure but that was present from the start of accessibility being enabled on Mac - see bug 862238).

The regression here is from bug 963105 - I've verified it using try server fixed to before & after revisions.

Potentially useful links:

http://hg.mozilla.org/comm-central/annotate/2f2fa58f41a7/mail/test/mozmill/message-header/test-message-header.js#l981

http://hg.mozilla.org/comm-central/annotate/2f2fa58f41a7/mail/test/mozmill/message-header/test-message-header.js#l892

http://hg.mozilla.org/comm-central/annotate/2f2fa58f41a7/mail/base/content/msgHdrViewOverlay.xul#l411
Blocks: 963105
Summary: TEST-UNEXPECTED-FAIL | test-message-header.js | test-message-header.js::test_a11y_attrs → Permanent Orange: TEST-UNEXPECTED-FAIL | test-message-header.js | test-message-header.js::test_a11y_attrs
Attached patch accesskeycontrolSplinter Review
Setting labelElement should happen even when no accesskey is set.

Mark, as I can't seem to build Thunderbird right now, could you verify if this fixes the failure?
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8373516 - Flags: feedback?
Attachment #8373516 - Flags: feedback? → feedback?(mbanner)
We attempted a try run with this patch at https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=360adfeb091b . Hopefully the /toolkit patch got applied there (on c-c), but the failing test now passed.
Attachment #8373516 - Flags: review?(neil)
Comment on attachment 8373516 [details] [diff] [review]
accesskeycontrol

Just to confirm, the patch applied fine on try server.

Thanks for fixing this.
Attachment #8373516 - Flags: feedback?(mbanner) → feedback+
Attachment #8373516 - Flags: review?(neil) → review+
Comment on attachment 8373516 [details] [diff] [review]
accesskeycontrol

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 963105
User impact if declined: fixes regression where textbox labels won't be available to accessibility 
Testing completed (on m-c, etc.): yes, passes on try server, tested by thunderbird folks
Risk to taking this patch (and alternatives if risky): none, only restores code that should have been executing, no new code
String or IDL/UUID changes made by this patch: none
Attachment #8373516 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ad74d750e5a5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 30.0
Attachment #8373516 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 971961
You need to log in before you can comment on or make changes to this bug.