click in the padding of a text input and drag your mouse to highlight the text in the field it stops at the right of the visible area and doesn't scroll

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: reynish, Unassigned)

Tracking

28 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36

Steps to reproduce:

http://codepen.io/reynish/pen/AaKli

Input type text with padding applied. Value of input is longer than visible area. Click in padding and move mouse to highlight text in field.


Actual results:

Visible text in input is highlighted. No scrolling to highlight the rest of the input.


Expected results:

Value of input should scroll to allow selection of entire input value.

Comment 1

4 years ago
Hi
Thanks for the report.

I can confirm and didn't find a dupe. This seems really annoying to me. But this is the wrong Product, please move it to the following location:

Product: Core
Component: Layout: Form Controls

Btw, another workaround would be to use Ctrl + A.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
I can't confirm on Linux. Might be Windows-only?

(@sjw, what platform did you reproduce this on?)
Oh, wait! I *can* reproduce in *release* on Linux (Firefox 27), but I can't reproduce in Nightly.  So I suspect this might have been fixed on trunk (but the fix hasn't made it to release yet).
WORKSFORME in Aurora 29, too.

sjw or reynish, please reopen if you can reproduce in Aurora ( https://www.mozilla.org/en-US/firefox/aurora/ ); otherwise, it looks like this has been fixed & just hasn't made it to release yet.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 5

4 years ago
Hmm... I'm pretty sure that I was using Nightly.
But anyway, I can confirm this as fixed now.
You need to log in before you can comment on or make changes to this bug.