Print XUL/XML elements (in console.log/error/whatever) similar to how HTML content gets handled

RESOLVED DUPLICATE of bug 952190

Status

RESOLVED DUPLICATE of bug 952190
5 years ago
3 months ago

People

(Reporter: Gijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Because stuff like:

XULElement {_lightweightTheme: Object, className: "", align: "", dir: "", flex: "", flexGroup: "", ordinal: "", orient: "", pack: "", hidden: false}

Makes me sad. Especially because the output is mostly entirely the same for different XUL nodes so I can't tell them apart without clicking on them to open the details pane.
Thanks for the report.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952190

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.