connection errors show hostname with &f=regular appended

RESOLVED DUPLICATE of bug 967342

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 967342
4 years ago
4 years ago

People

(Reporter: glob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Nightly/29.0a1 (2014-02-03)

steps:

1. visit a url with a hostname that does not resolve
   eg. http://cheese.example.com/

2. read error message

actual:

> Server not found
> Firefox can't find the server at cheese.example.com.&f=regular

"&f=regular" is included in the error message, but isn't present in the request.

expected:

> Server not found
> Firefox can't find the server at cheese.example.com

Comment 1

4 years ago
Me too with Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 so it is not Mac specific.
OS: Mac OS X → All

Comment 2

4 years ago
Possibly duplicate of bug 967342 ?

Comment 3

4 years ago
It really is.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967342
You need to log in before you can comment on or make changes to this bug.