Banner Alerts of Your Error Below

RESOLVED WONTFIX

Status

Webmaker
Thimble
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: omnignorant, Assigned: pomax)

Tracking

Details

(Reporter)

Description

4 years ago
Right now, you can have an error like 50 lines down and not even know it. You can also scroll right past it and miss it. Can we add a banner that notifies you clearly that there's an error, what line it's on and maybe reacts when you scroll to it?

This is critical because:
1. Errors disable the tag help functionality (i.e. you can't click into tags for the nice orange question mark for help);
2. This enables the remixing of thimbles with errors. If you don't scroll down but change the title or other minor changes, then publish, you add another buggy make to the pot.
(Reporter)

Updated

4 years ago
Assignee: nobody → brett
I agree - a "door hanger" alert that lets you know not just the specific line, but that you have an error, would be useful.
Assignee: brett → pomax
(Assignee)

Comment 2

4 years ago
we had that last year, after which the user comments were "the error message is super in the way", so we can make it always show again until you address it, but this too will be blocked on Slowparse being a perfect parser then, since it will currently flag errors on content that is not wrong, just wrong "according to slowparse".
(Reporter)

Comment 3

4 years ago
Well, I think the core concerns are items 1&2 that make this critical. I guess those are the real bugs.
IIRC users were more annoyed that they couldn't continue with their work with the previous error message.  This bug suggests we should just let them know they have one via a doorhanger at the top of the editor window, to address the fact that you might have an error, but it could be far down the page.

Perhaps the door hanger could say "you have an error on line 52" with a link to that line?  Users could still work, but they'd know they have an error somewhere on the page.

As to the efficacy of slowparse, I can't comment.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 967057
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 967575
(Assignee)

Comment 7

4 years ago
marking as normal, as it's not actually critical, just a sensibly good idea.
Severity: critical → normal
(Assignee)

Updated

4 years ago
Blocks: 957736
(Assignee)

Comment 8

4 years ago
unassigning, I will not be doing this for a while until appmaker's up and running.
Assignee: pomax → nobody
Status: ASSIGNED → NEW
(Assignee)

Updated

3 years ago
Assignee: nobody → pomax

Comment 9

3 years ago
Covered in https://github.com/mozilla/thimble.webmaker.org/issues/494
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.