Closed Bug 967572 Opened 6 years ago Closed 6 years ago

DevTools Light theme text input border is a bit dark

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(firefox29 verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: bgrins, Assigned: bgrins)

References

Details

Attachments

(3 files)

Attached image text-input-border.png
See attached screenshot.  It should be lighter
Splits out the border color as a setting per theme
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8370124 - Flags: review?(vporof)
Screenshot with patch applied
Comment on attachment 8370124 [details] [diff] [review]
theme-search-border.patch

Review of attachment 8370124 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/devtools/toolbars.inc.css
@@ +213,5 @@
>  }
>  
> +.theme-dark .devtools-textinput,
> +.theme-dark .devtools-searchinput {
> +  border-color: rgb(88, 94, 101);

Where is this color coming from? Should we use a color from the palette instead? If so, please document it as well.
Attachment #8370124 - Flags: review?(vporof) → review+
(In reply to Victor Porof [:vp] from comment #3)
> Comment on attachment 8370124 [details] [diff] [review]
> theme-search-border.patch
> 
> Review of attachment 8370124 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/themes/shared/devtools/toolbars.inc.css
> @@ +213,5 @@
> >  }
> >  
> > +.theme-dark .devtools-textinput,
> > +.theme-dark .devtools-searchinput {
> > +  border-color: rgb(88, 94, 101);
> 
> Where is this color coming from? Should we use a color from the palette
> instead? If so, please document it as well.

I showed screenshots to Darrin with both the current color, compared with the corresponding dark theme color (black in this case), and he preferred to just stick with what was already there.
https://hg.mozilla.org/mozilla-central/rev/da727ba3a9fa
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Blocks: 966661
Comment on attachment 8370124 [details] [diff] [review]
theme-search-border.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: Contrast between search input and toolbars in DevTools light theme will be too high
Testing completed (on m-c, etc.): On m-c since 2-06
Risk to taking this patch (and alternatives if risky): Low risk change - CSS update to DevTools only
String or IDL/UUID changes made by this patch:
Attachment #8370124 - Flags: approval-mozilla-aurora?
Attachment #8370124 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified with latest builds of Nightly and Aurora
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.